Mailchimp's JS not working on server

Hey guys, so I have this problem which i believe is javascript related, its a simple mailchimp signup form which I would like to display it’s standard “error” “is blank” or “success” messages. Now I have this working example going on codepen : Codepen Link but, when i port this over to the working server on the test file…no alerts, messages or anything. Could anyone tell me why it works on codepen and not on our server?
Not Working Real Version
The form will appear after a second or two in a modal window. Thanks in advance everyone.
-Brent

<script type="text/javascript" src="//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js"></script>

Can you show me where on your real version you invoke this Javascript? (Hint: You cant get errors from a script you dont load…)

I guess I’m a little confused with what you are asking. I tried throwing the script you referenced above onto the test.php page earlier but to no avail. I still got no responses when I tried to submit both proper & improper email addresses. So I copied part of the above referenced script into my own .js file : https://mountainviewpaf.com/cdn/theme-validate.js - but that proved no better. Now the reason I moved part of that mailchimp script into a new .js file is because I already load a verison of jQuery 3.0 into the site via a https://mountainviewpaf.com/cdn/theme-vendor.js file in the footer & did not want it to load two different versions of jQuery as mailchimp’s file includes an earlier pre 2.0 version of jQuery.
Now my test.php file in the original posting, it now contains a reference to the mailchimp script you mentioned above. I had to throw it in the footer above the theme-vendor.js file as to not get them to conflict.
The form is submitted in a standard fashion through a post method in the form, but the mailchimp script validates correctly on my codepen link, referenced in my original posting, but not once I get it onto my server.

Load the entire script, and try again.

If your problem is “It works here but not there”, and the difference between here and there is that you’ve got the whole thing loaded in one but not the other… you’ve identified the problem?

Thank you, I was able to track down the issue. It was a conflict between two variables. 1, the mailchimp validation script required jQuery 1.9 & I was running jQuery 3.7 for functionality of existing elements on the page. 2, a jQuery cookie plugin conflicted with it.

I find it odd that Mailchimp uses that old of a jQuery version still, but… shrug I’m not their versioning department :laughing: