Icomoon problem

Icons are not loading on the page while font-awesome icons are for some reason.

SIte is located in content folder of my ftp and I made sure to link all the css to it properly (font-awesome pulls through correctly)

Can’t really spot the error here, please help

I have issues with this sometimes. However, you have failed to tell us where the icons are not appearing. You left us in the dark :slight_smile: .

Are you sure you are using the correct code that IcoMoon provides? E.g. \e606 or whatever in the content property of :before / :after? Just shooting in the dark :slight_smile: .

Hi Ryan sorry, it’s below under Offer Room. You can see there are square icons there while the one working is from fa.

Also if you click on facilities it has lots of square icons not displaying from icomoon

Now, where do you believe that the IcoMoon files are being stored live? Please grab me the direct link to an IcoMoon file :slight_smile: .

The CSS for it is being called; just not linking up with your IcoMoon file. So there is a discrepancy to where the font files aren’t being properly called.

It should be http://www.sntravel.co.uk/content/fonts/icomoon.woff is that what you needed?

Yup. That was perfect. Thank you :slight_smile: .

So this is your CSS:

font-face{font-family:'icomoon';src:url('/custom/fonts/icomoon.eot?v=4.0.3');src:url('/custom/fonts/icomoon.svg?v=4.0.3#icomoon') format('svg'), url('/custom/fonts/icomoon.eot?#iefix&v=4.0.3') format('embedded-opentype'), url('/custom/fonts/icomoon.woff?v=4.0.3') format('woff'), url('/custom/fonts/icomoon.ttf?v=4.0.3') format('truetype');font-weight:normal;font-style:normal;}

Why are you looking in /custom/ in your CSS but you actually want ti be looking in /content/ :slight_smile: ?

2 Likes

cause I’m an idiot? lol I didn’t notice I wrote custom instead of content there

1 Like

Fair enough :slight_smile: .

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.