Http error 404


I installed WAMP server…

When I go to localhost iam getting this is

HTTP Error 404. The requested resource is not found.

how to solve this

I am not sure whats going wrong but hopefully following links might help you-

check whether you have installed 2 or more DBMS…for example,suppose i have installed mysql and oracle both,then WAMP server will give 404 error.In that case,you need to change mysql ports

What are you typing into your address bar.

It should be something like localhost/folder/file e.g. localhost/rubblewebs/index.php

What happens when you enter as the url?

when i type im getting the same error

In your taskbar what color is the WAMP icon??

Sent from my iPhone using Tapatalk


when i click start all services im getting…

could not execute menu item(internal error)[exception]could not perform
service action.The service has not been started

Shud i change skype port??
if so how to change skype port and how to fin the port for wamp server

Skype has a built in feature that allows the port to be changed, if you do a google search you will find the information to change it.

Sent from my iPhone using Tapatalk

but the wamp icon in the taskbar is orange in color

wamp server still not working some one help to solve this error

when i click start all services im getting…

could not execute menu item(internal error)[exception]could not perform
service action.The service has not been started

Here are a few suggestions I would try:

  • Hit start, type services.msc, scroll down and look for wampmysqld and wampapache - make sure both are present, and started. If they are not, do the following:
    o If they are not present, click the wampserver icon, select the service (Apache for wampapache and MySQL for wampmysqld), then Service, then Install Service
    o If there are present but not started, try starting them. You can right click them, properties and click Start (and if you like set them to automatically start too to start when Windows does) or you can do the same as the previous step from the WampServer icon
  • Have you sorted out Skype? There can’t be anything on port 80 or Apache won’t work (unless you configure it to use another port in your config, but I’d suggest not doing that). If you have, and it’s still not working, try removing all the services (in your wamp folder will be a batch script, called something like uninstall_services.bat) - run this and then install the services again. Note that when you install the apache service it will run a script that checks port 80 is free, and it will let you know whether it has been successful or not
  • If you have changed the config I suggest reverting back to the default to start. Regardless, you can check the syntax of your Apache config with the following command: httpd -t (you run this from a command prompt - start -> run -> cmd). Note that if the wamp/apache/Apache2.x.xx/bin folder isn’t in your PATH variable you will need to navigate to that folder in the command prompt or shift+right click inside the folder and select Open Command Window Here

If all of that fails let us know and we’ll try some more stuff :slight_smile:

P.S. don’t worry too much about the error message from the tray icon - these errors happen a fair bit with WampServer, always have done. Everything can be modified/fixed manually via config files, command line and services.exe :slight_smile:

Have you had a separate install in place previously (separate installs of MySQL, PHP and Apache)?

Have you checked your firewall settings?

Do you have IIS running?

What version of WAMP are you trying to install and onto what version of windows?

Go to Apache>httpd.conf change #Listen
Listen 80


                                                  Listen 8080

go back to your browser and try http://localhost:8080 it should work.

I had this same problem with wamp-so i searched and found this solution which actually worked for me
I had SQL Server 2008 installed in my PC so the port 80 was being used by this.
No matter what port i assigned wamp in httpd.conf but the problem did persist…
So i simply disabled all the services related to SQL Server by going to services.msc particularly the SQL Server Reporting Service.
So thats how i fixed the issue.
Hope this helps…