New wamp server installed-HTTP error 404.4

I just installed newest wamp server, and now HTTP (error404.4) says I need to configure or map a handler for file extension. Tried to go to [C:\ inetmgr] , but search didn’t find inetmgr. I did manage to find file extension set up in the Control Panel, but not sure what I’m supposed to do. Tried using simple php file
[ <?php
?> ]
in Dreamweaver (without the ) and got same browser message (error404.4). I don’t know where to go from here. Looks like something didn’t install correctly or Vista’s messing up again. Guess it’s obvious I’m a newbie. Can anyone advise me?

Make sure you know the address of your document root and put your phpinfo() file in there

Use this and name it index.php for now.

<h3>This is html</h3>

echo 'PHP says ... <br />';



Then fire up a browser and go to http://localhost or

Now what are you getting?

same thing. I can’t seem to start the service for some reason.

If you are getting a 404 message then your service has started.

How do you know what your document root is for your localhost website?

I assumed it was in the programs, wamp, www folder which is where I “pathed” my php site; Not?
But when I go to the wamp icon and select “put online” I get an error message indicating that the service hasn’t been started (even though I already selected to start all services).

Sorry, I am not a wamp user, I cannot help you … can anyone else help?

Thanks for trying…

I’m a bit clumsy navigating this forum, too (sorry). Would you please let me know if I have should list my request/problem in a different thread than php?

No, you are in the right place…

Have you tried: (win2k server anyhow)

Start / Programs / Administrative Tools / Services / then on the list look for “Apache” or “www server” then stop/start/restart ?

Then you’d know that your webserver had started.

Listen, we are going to keep at it, eh?

oops; don’t know if I sent my msg or not. I’ll send same info again jic.
Glad you’re still with me…Thanks
I did as you suggested and it seems that wampapache can’t start (event id log #3299) and there is no online info for the problem… I really suspect some kind of switch needs to be set; maybe something to do with Vista.
I tried starting it manually from task mgr, but got the same error.
However, wampsqld indicates “started”, but I still get that browser 404-4 error code when I go to localhost.

I just checked my firewall which shows mysqld-nt.exe “Allow”. I can add apache, but I don’t know which exe file to specify, and there are lots in the bin to choose from (httpd.exe, ApacheMonitor.exe for example). I’m not convinced the correct mysql exe was (automatically selected) either.

is the WAMP icon in the tray at the bottom of the screen all white? The only problem I have had with this is PORT 80 being in use, for me it was SKYPE so I closed it and it worked fine. When it is working and you type http://localhost it should bring you to the main wamp screen.

The wamp icon is yellow and white. How can I check about the port (it rings a little bell somewhere…)or SKYPE?

To check port 80 click on the wamp icon thing and go to apache>services>check port 80

Skype is a chat thing I use to talk online. But other programs use port 80 also.

I have to go to work now but there are forums at the wamp site that were really helpful for me.

I will check this thread when I get home and see how you are getting along.


I checked port 80; it is actually used by Microsoft-IIS/7.0—not sure if that’s important or how to change it.
I also happened to notice that wamp installed directly on C drive as opposed to c:/program files. I tried just cut and paste to move it into program files, but that didn’t work so well (couldn’t get the menu up), so I moved it back. At least I can get my wamp icon and menu again.
I’ll keep posting.

Did you install IIs previously on your computer?

Wamp does install to the root that is correct. Try shutting down IIs then restart the services in wamp and see what happens.

I tried what you suggested (shut down my server), but unfortunately nothing changed when I started wamp; and port 80 is still occupied.
I did some digging yesterday…
Evidently Windows included IIS on my notebook, which has an html “help” file, but the critical file “inetmgr” is missing (no search finds it anywhere), and this is the file that you use to set everthing up for php etc. I do have a folder called inetpub, which contains a wwwroot folder with iissstart—but without inetmgr, I just can’t seem to do anything.
I can download an IIS/7 upgrade for my lovely Vista if I have sp1, however, according to users, sp1 causes crashes, etc. and I’d rather not try it.

Maybe I can direct wamp (or preferrably IIS/7) to a different port, but I don’t know how to do that.

Try and put the above file in c:\inetpub\wwwroot\ as index.php

Then fire up a browser and go to http://localhost/index.php or

Maybe your problem is that IIS is determined to serve content from its default directory?

Done, and same, same…
This is what the HTML 404-4 says:
This error means that the Web server does not recognize the file extension of the requested resource. A module handler is not configured on the Web server for this extension. If the file extension being denied is required by the Web server, add the appropriate handler for the file extension.
Server Version Information: Internet Information Services 7.0.

That’s the kind of set up that inetmgr is for (handlers, etc.) but it is missing.

I believe wamp has everything it needs, except for a port, and its nice to work with. I used it before I upgraded, and that’s why I’m confused. It was all automatic…Download, Install, Start, and go.

Maybe the problem is because of a Windows update to IIS/7.

Do you know if the port can be modified or will it cause my server to self-destruct?

Try and put the above file in c:\inetpub\wwwroot\ as index.htm then?