How to connect to localhost with an FTP client

I have installed phpdev3 on my computer. Now I would like to test some scripts and I have to chmod them. I think that the only way to do that is by using an FTP program (I use Flash FXP). The problem is that I can’t connect to localhost because I don’t know the username and password. (I have never assigned them.) What should I do?

Unless you are running an FTP server on your localhost you can’t ftp to it? But a bigger question at hand is what scripts need to have permissions changed? PHP scripts don’t need any special permissions when running locally. Text files by default should be writable by all in a windows enviornment. Could you elaborate?

You will probably have to install an FTP Server. I don’t know how necessary that is though, since it is on your own machine.

What version of windows are running?

ah, freddy beat me…he knows more about this stuff, so I would take what he says more then what I said. :slight_smile:

Well I downloaded a guestbook from Hotscripts and according to the readme text some files have to be chmod:ed.

You will need to CHMOD these important files to these modes.

   nconf.php	666 or 777
   news.txt	666 or 777
   archive.txt	666 or 777
   headlines.txt	666 or 777
   maillist.txt	666 or 777
   nphpd.dat	666 or 777

I don’t really understand why, because they seem to work fine. Just wanted to follow the instructions… I guess that the problem is solved. Thanks! :slight_smile:


Those permissions listed are unix permissions, which tend to be whole lot stricter than Windows permissions. The reason is simple, those files need to be able to be written to on a unix machine which mean making sure that everyone has at least read and write privileges to the files. 666 or full read, write, execute privileges 777. So yes in ordeer for your script to function properly on a unix machine you would need to set those permissions. However on Windows machine you cannot set 666 or 777 or any other unix permission on files and by default you shouldn’t need to, as your local computer already has full permissions on those files. I hope that clears it up.

I have installed phpdev3 on my computer

so you are using Windows right ?
No CHMOD in Windows … they should work without setting CHMOD

Edit: Sorry freddydoesphp, did not see your post … less than 1 min difference :slight_smile:

All files are writable on Windows, so you do not have to change file permissions

Sean :slight_smile:

Thank you for explaining. I wish that the install instructions that come with free scripts would be as good as your posts. :wink:

Originally posted by seanf
All files are writable on Windows, so you do not have to change file permissions

not if they’re Read-only. phpBB, i know, makes you make the config file read only for security reasons. then it’s no longer writable. :slight_smile: