Having trouble getting started with HybridAuth on Windows

I downloaded HybridAuth latest version from the Github repo https://github.com/hybridauth/hybridauth/releases/tag/v2.3.0

I followed the instruction at http://hybridauth.sourceforge.net/userguide/IDProvider_info_Facebook.html to get the facebook login working…

Each time i visit the installation url, i get this error

Not Found

HTTP Error 404. The requested resource is not found.

Am running Xampp with PHP 5.6.3

Help needed.

Does the file exist in the correct location?

Yes it does.

I tried using Twitter from this example http://hybridauth.sourceforge.net/userguide/Integrating_HybridAuth_SignIn.html

// start a new session (required for Hybridauth)

$config = [
   "base_url" => "http://localhost/hybrid-auth/index.php",
   "debug_mode" => true,
   // Path to file writable by the web server. Required if 'debug_mode' is not false
   "debug_file" => "bug.txt",
   "providers" => [
   "Twitter" => [
      "enabled" => true,
      "keys"    => array ( "key" => "l2y14LEZPIR5ZO2efGTiNLLB2", "secret" => " xLApHwq9zyH0pr97xxw3ojgtamRS2cBzo2oATZl2SeIrVx8dCl" )

require_once( "Hybrid/Auth.php" );

// init hybridauth
$hybridauth = new Hybrid_Auth( $config );

// try to authenticate with twitter
$adapter = $hybridauth->authenticate( "Twitter" );


// return Hybrid_User_Profile object intance
$user_profile = $adapter->getUserProfile();

echo "Hi there! " . $user_profile->displayName;

Still same error.

Figured it out… you won’t believe the cause of this ish…

PHP wasn't running i.e it was disabled. all this while i thought it was up.

You’re correct. I dont believe that is the cause.

404 errors arnt generated because PHP is disabled. You simply would have gotten the script file as interpreted as HTML.
404 errors are generated because the file isnt where it’s supposed to be, or your URL is incorrect.

You are very right…

Thanks for your time.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.