Blaming the Developer - Blaming the Hosts - Cycle

I have a VPS server. There are times when I try to go to my sites admin section, it will say “Connecting” and it may take 2 or 3 minutes to connect to my admin section. I tried several different browsers and it occurs no matter which browser I use.

I talked to my host and they say it is related to the coding of the script. I talk to the developer and they say it is the server performance. The blame game isn’t helping me solve the problem. I’m hoping there is a way I can test my server to see if the problem is related to my host.

Any feedback would be appreciated.

p.s. I tried this tracerout command, but those numbers don’t mean anything to me. Isn’t there something that explains if it is good, bad or whatever in plain English.

Is your hosting service overseas? I’ve found this in the past with overseas hosts, which is why I decided to go local in the end, despite the extra expense. Not sure why the admin section tends to be so much slower than the front end, but certainly that’s what I’ve found.

No it is a U.S. server. I’m not sure why either. I just don’t have the knowledge to figure it out and like I said, my host and developer each blame the other for the problem so I’m looking for tools I can use to find the problem myself.

They both could be right – the developer is probably working on a much more powerful machine than your VPS. And he might well be working with a much smaller dataset. I would ask the host why they think it is the developer and if they have any measurements to back it up. I would also ask the developer how they are performance testing, particularly how much data they are working with. In any case, getting some measurements to figure out what is slow is the first step. What happens when that page loads?

“connecting” implies its waiting for the server to respond first. However if the front of the site works and its just the admin that takes time… I’d be inclined to say the code needs looking at.

http / https ? Any extra security on the admin that doesn’t exist on the site?

Depends what is being loaded / what the admin scripts are doing extra, it could well be both to blame.