413 Request Entity Too Large


#1

The requested resource URL does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

I get this error when trying to submit a rather large form. I have set the upload_max_filesize=20M and post_max_size=0 in PHP and also set LimitRequestBody 20971520 in Apache and then restarted Apache. That had no effect on the issue so it still remains.

Any ideas what is causing this? Thanks


#2

Doesn’t this need a value?

Sets max size of post data allowed. This setting also affects file upload. To upload large files, this value must be larger than upload_max_filesize.
http://php.net/manual/en/ini.core.php#ini.post-max-size


#3

Perhaps more relevant is the changelog info

Changelog for post_max_size

Version Description
5.3.4 post_max_size = 0 will not disable the limit when the content type is application/x-www-form-urlencoded or is not registered with PHP.
5.3.2 , 5.2.12 Allow unlimited post size by setting post_max_size to 0.

#4

Thanks for the input. Turns out the culprit is an Apache config file called SecRequestBodyNoFiles parameter that resides in /etc/httpd/conf/mod_security.conf. Once I set that and restarted Apache all was fine.

Was just coming out here to indicate that so I do appreciate the reply.