Xdebug does not display html style on browser

I use the XAMPP program.
I installed and configured Xdebug . Everything works fine on VSCode .
But when it displays errors in the browser, it has no style and the appearance of the errors has not changed at all.
I also set in PHP.ini:

html_errors = On

But still without html style.
what’s the solution?

Try editing the php.ini file, search for “’<span’” and edit to suit your requirements, don’t forget to change </span> AND to make a copy of the file… because syntax errors are ignored and a default php.ini file used!!!

I use ‘<pre` and add margin and colours which work quite well.

Problem occurs when php is updated and changes to php.ini are overwritten. :frowning:

Edit:

I’ve yet to discover how to add line feeds to the Apache2 error.log and would be grateful for any advice, even a simple additional line feed would be beneficial in making log files more readable.

1 Like

No, my problem is not solved yet.

Did you update the system because PHP settings are compiled.

Update Using Linux Operating System:

systemctl reload apache2

1 Like

Yes, i did.

There could be more than one php.ini file, ensure you modified the right one.

Test by temporarily setting the following:

<span style="font-size: X-LARGE;">
1 Like