Www.dlinkddns.com redirected to instead of

I’ve been creating a Website, and for all intents and purposes, it is working fine.

However, the problem here is that I cannot properly access www.dlinkddns.com on my PC , which is the dynamic DNS service I use for my Website. Instead, it brought me to the webpage that I had locally stored. I will want to access it to check if there’s anything wrong, but my PC isn’t letting me.

On the flip side, I can successfully visit the dlink site when I use my Samsung Galaxy S4 and the problem is nonexistent.

*When at my router config page ( model: DIR-615 ), I clicked at a link that would normally bring me to www.dlinkddns.com. Instead, it brought me to the webpage that I had locally stored.

Here are the points of interest that I may have so far uncovered:

  1. I have used 2 devices while trying to solve this problem. 1 Samsung Galaxy S4 running Android 4.4.2, and the other, a custom built PC running Windows 7 64-bit.

  2. Both devices are using connected to the same router, the Samsung Galaxy S4 by Wi-Fi and the custom built PC by physical ethernet connection.

  3. Thinking that it may be a problem related to the hosts file, I created a backup of the entries, and then deleted everything in the hosts file. The problem wasn’t solved when I restarted my PC.

  4. While pinging the dlink site from my Samsung Galaxy S4, the returned IP address was :

  5. While pinging the dlink site from my custom built PC, the returned IP address was :

  6. I typed in the browser of my custom built PC, and although it was able to connect to the dlink site successfully, Google Chrome says that : “The identity of the website has not been verified”. I don’t think it’s wise to continue using this method of connecting to the dlink site.

It is at this point that I ask for help. Here is the lead that I think is correct:
Something is redirecting my custom built PC to connect to instead of when I try to connect to the dlink site.

Or it’s a problem with the router, but I doubt that, because my S4 was able to connect to the dlink site using the same network, albeit by wireless connection.

Or it’s my ISP doing something to redirect my PC. However, I see no reason for my ISP to redirect me away from a Dynamic DNS website.

I have tried searching Google but the search results are always irrelevant when “dlinkddns” is included in my search query.

Thank you in advance to anyone that will take the time to read and provide relevant answers.

Hi @kweijin97

And welcome to the forum.

I think there are two problems, firstly the hosts file which is mainly used for localhost redirection of and should have no reference to http://www.dlinkddns.com/

The second problem being browser caching. This problem can be cleared completely and should solve your problem otherwise open a new browser or your old browser in incognito mode (no cache).

What operating system are you using?
Please ignore, just noticed you are using Win 7 64 bit

Hi @John_Betong,

I believe it is worth reiterating that I have already checked the hosts file thoroughly. Perhaps it wasn’t clear in my initial post, sorry.

Anyways, before coming here and seeking for help, one of the solutions I tried was to delete everything in the hosts file (with a backup of entry), and then try to connect to the site again after restarting my PC. Well that didn’t solve the problem. I suspect that it isn’t anything to do with the hosts file.

I’ve tried connecting to the dlink site in a newly bought laptop, running Windows 8.1 64-bit with no programs installed except for the manufacturer’s preinstalled ones, and Google Chrome. The hosts file probably hasn’t been altered by any program that was installed, and I am quite sure I did not touch the hosts file in any way. Note that both of these systems were tested in the same network. I think it may be time to consider that this is a problem that is out of my control.

Thanks for replying, John.

EDIT: The error message I seem to be getting from Chrome is : “ERR_CONNECTION_REFUSED” , and the description says that : " Google Chrome’s connection attempt to www(d0t)dlinkddns(d0t)com was rejected. The website may be down, or your network may not be properly configured. " . I have no reason to believe that my connection to www(d0t)dlinkddn(d0t).com should be blocked, as there should be no malware on my new laptop and close to no programs installed.

**EDIT: ** One more thing, and is that I am getting the same errors when trying to connect to https:(double forward slashes)malaysia(d0t)kinokuniya(d0t)com , while having no problems connecting to www(d0t)kinokuniya(d0t)com/us/ . I don’t see any relationship between a website for dynamic DNS and books.

UPDATE: Just I’ve just used the new laptop on a separate internet connection, that of my phone. I am able to connect to the websites just fine now. But why can’t I connect to the websites using my home’s internet connection? I don’t see it as a problem with my home connection either, as I am able to connect to the websites using that connection by using other devices, such as my PS4, Samsung S4, Ubuntu 14.04.3 LTS on the very same Windows PC that is still giving me problems, and a secondary laptop that has Windows 8.1 installed.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.