Why is Index of/ showing

When I go to my admin page I usually type website.com/admin
Then I end up at the index.php page.

But now, all of sudden a list of all the files in that folder are shown like Index of/
Don’t know what I might have changed… is there a way to get that back to automatically load the index.php file instead?

It sounds like one of two things:

  • The PHP file is no longer present; or

  • The PHP processor is no longer running (on the server).

Either way, you should talk to your hosting company or administrator.


i think that PHP is not present, try checking it again

Well, if I write website.com/admin/index.php it shows up. But it used to show up when I only wrote website.com/admin
Maybe I changed a setting on the server, but not sure which one. I didn’t get a good answer from the hosting company either. Maybe I should try them again…

Sounds like for some reason you don’t have a DirectoryIndex anymore.

Try putting this in a .htaccess in the root of your website:

DirectoryIndex index.php

If there already is an .htaccess there, please post its contents.