Want to Start Learning but cant get passed making MAMP Pro and PHP Storm working?

I want to start learning PHP and I started on lynda but I have hit a road block before I can even start my practice. I first watched a video on setting up my environment to work with php. I have posted my question on FIVE different places so far and no one has helped or answered any of my posts lol My question can be read here with pictures: http://izaguir.re/treehouse-forum-question/

So my question is regarding the question I posted on the link above, so please read that first.

I dont know if you would skype chat to help me for free so I was wondering how much you would charge to skype me and tell me what to do and what I did wrong so I can make this MAMP Pro and PHP storm work correctly so I can start practicing. The only issue is that .ini file, I don’t understand because when I rename it, it does not work with php storm. I am new… COMPLETELY new to all this so if its a simple fix I just don’t know since this is my first attempt.

I have been at this road block for a week -___-

1 Like

Mac comes with Apache and PHP already installed. if you want to use different versions, use a VM (e.g. via vagrant). If you want to change the versions for your Mac, install them via MacPorts or homebrew.

1 Like

Hi thank you for your response. But I don’t have a Mac , in the link I posted it says I have Windows and the Mamp Pro version of Windows. My question had nothing to do with versions ? But I appreciate the response.

1 Like

I don’t know how much help I’ll be for I run MAMP PRO on an iMac, but I think since you are running MAMP PRO on Windows that you will have to configure the localhost to the port your computer uses for it? You’re going to have to do an internet search on how to exactly do it, but I think you have to bring up the cmd prompt (c:>_) and type sysinfo (or something like that) to bring up what port you can use? It’s been about 4 years since I used a Windows based PC though I work and build them for 30+ years before that.

1 Like

Hi, welcome to the forum @ian69 :slight_smile:

“502 Bad Gateway” Seems you have not made the necessary entries in the “hosts” file.

This thead has info about doing that: Installing multiple Wordpress Sites in Xampp - #2 by cheesedude

Here is some other info on the same using XAMP but the Windows version: http://nurelm.com/setting-up-a-virtual-host-with-xampp/

1 Like

I have Windows not a mac but MAMP works with windows so I bought the Pro version.

As far as I understand WAMP is to be used in Windows and MAMP runs on a Mac IOS computer.

WAMP is free so why did you purchase MAMP?


I dont know literally anything about these programs yet. I purchased MAMP Pro because in the set up video on lynda it was number 1 on the recommended list for windows and mac. WAMP was his number 2 for windows. MAMP was free for windows or you could get the Pro , again I dont know anything yet but I just started with the pro to avoid having more confusion if I needed a feature that the free did not have.

1 Like

Hi thank you, but those thread links say XAMP but i have MAMP , so I dont know if it would be the same help ? would it?

I sent an email with my question to the PHP Storm staff and in the reply they sent, they told me to follow a link to setup apache in MAMP to connect with PHP Storm. I just went to their forums and posted in detail ALL the steps I did. Here is the link to that thread: https://intellij-support.jetbrains.com/hc/en-us/community/posts/115000047910-Using-Windows-Just-Installed-MAMP-Pro-and-PHP-Strom-but-dont-understand-how-to-get-CLI-interpreter-to-work-

I Hope someone here or there can help me further. I appreciate the responses here so far, this is the first time people have answered this particular post since in the 5 other sites I posted it went ignored. So Thank you for helping me through this problem, so I am very thankful and will be active in the future on this particular forum due to that :-). I hope I can solve this lol

Any more advice is welcomed after you read the link I posted with the new clear steps I listed

1 Like

It is a couple of years since I last used Windows. I successfully tried both Xamp and Wamp but cannot remember ever using CLI.

I have never used a Mac’s IOS system.

Perhaps another poster could help?

Installing PHP shouldn’t be costing a dime. Especially since PHP is open source and you can practically install it with an eye closed. I’m creating a tutorial on how to install PHP on Ubuntu and on Windows without any 3rd party programs like XAMPP, WAMP, or MAMP. I will be posting the thread later on tomorrow if I can finish it or later on in the week.


As you’ve got the paid version can you not get support from MAMP?

I have not asked them yet? Maybe I should. I first asked PHP Storm for help since I dont know if my problem is more with PHP Storm or with MAMP , but both are paid but the PHP storm I got for free since I am a student - they give you free access with showing a student ID every year. I will wait to see if the PHP Storm help I submitted by email and forum post gets a follow up reply, if not then I will ask MAMP for support

Quoting your post on JetBrains.com:


Under Upload/download project files there is the title “Folder” / I selected browse (…) / My path is C:\MAMP\htdocs

Under Browse files on server / for Web server root URL , I changed the URL to
http:// localhost:8888 /

I pressed “Open” / A web page displayed saying :

The virtual host was set up successfully.
If you can see this page, your new virtual host was set up successfully. Now, web content can be added and this placeholder page1) should be replaced or deleted.
Server name: localhost
Document root: C:/MAMP/htdocs

  1. Files: index.php and MAMP-PRO-Logo.png

Section B ) My questions

  1. Did I do anything wrong?
  2. Is that warning to replace/delete a file normal?
  1. All seems ok, the localhost is showing the server’s “internet root” directory where all your virtual hosts will reside. Now you can edit the “hosts” file as I posted above. (http://nurelm.com/setting-up-a-virtual-host-with-xampp/)

– Yes, the instructions for editing the Windows “hosts” and the Apache “httpd-vhosts.conf” files was for Windows.

  1. Yes. But you could also leave them there. (Those files is the localhost using the Apache server’s “internet root directory” as its own root directory for its files. You can even put links to your localhost’s virtual sites in that index.php and access them from there.)

When you have set up a virtual host it will be accessed as a site in that directory, the “internet root” for sites on your machine. The virtual host site will be accessed as myhostsdomain.com or whatever you name it in the Windows’ hosts file.

Post again how you did if it’s not working.

1 Like

Thank you for those instructions. I followed them but it did not work. But I went to youtube and saw this https://www.youtube.com/watch?v=4hMW8sTFftI , and I tried it and it worked. I think my paid version of mamp pro does what your instructions explained through the control panel which is what I believe that youtube video was showing. Was what your instructions showing and that youtube video teaching the same thing ? Or where your instructions for doing something different?

Glad you found a helpfull video, I guess I was trying to say much the same.

Happy you sorted it.

But I am confused because the CLI interpreter is not working still lol how do I fix that

I’m sorry, but I don’t get what the CLI problem is about.

Ok thank you all so much for the help… I actually found one problem I had that I thought was because of the interpreter no being set up. It turns out the problem was my directory path and not the interpreter. The project file path on PHP Storm I had was htdocs/lyndaPracticeFiles … but the reason it was not working when I tried opening up the browser was because the path should have just been htdocs/. I was being too specific in my first path since I thought the path I selected should have actually been the project folder itself not just the general folder where all project files could go.

So I will try to continue the tutorial and see if any more problems show up.

So the interpreter is still not set up but I guess it never had to be in order to get started, so I’ll see if I need it later on in the tutorial and then figure it out then. I don’t even know what an interpreter is for lol so that made me believe my initial error was due to that not being set up instead of my directory path . I got the idea that it was the interpreter causing the issue because in the tutorial he shows you an image of HIS php info screen and the interpreter section is filled while mine had “none” in the field since I had never set it up.

1 Like