W3c validation

Hi there:

I have been using the W3C validator to validate my xhtml Version 1 Strict pages. They all validate now, except for this one file. The problem seems to be in the doctype declaration, but the markup is exactly the same as all the other validated files. Frustrating! Can anyone tell me what the problem is? I have uploaded the url: www.kaikourahigh.school.nz/general.html
Jos M

I’d agree with VernonK regarding the erroneous white-space throwing the validator off the rails it probably expects an exact match hence why it though the error started at ‘x’ where the differing recommendations are kept, etc.

Try checking the “Clean up Markup with HTML Tidy” checkbox then copy and paste the generated output.

Thanks guys. It was really peculiar. I tried your suggestions but they didn’t work. However overnight I thought about it. I copied the existing mark-up into a new Notepad++ page and replaced the existing general.html. I uploaded the new general.html, and tried validation. It still picked up the same two errors but further down the page. At that point there was a space problem in the mark-up. I added the space, revalidated and yippee it validated!! This was my first forum thread so thank you - it made me feel less isolated. Jos:)

The Subject Info page is still using a transitional doctype. Sorry for the info about transitional below, shows me I should take extra reading time when I’m posting early in the A.M.

Try removing the single space right at the end before the closing tag. It’s the only difference I can find between that call and another valid page. The strange thing is the validation is pointing out the error in a weird spot.

The “attributes construct error” is an XML error if I’m right.

[s]Actually, they aren’t the same Doctype. If I look at the Subject Info page you are using an XHTML Transitional Doctype. However, on the page in question you have a Strict Doctype in there. The code on that page outputs a little weird as well.

Replace the Doctype on that page with the below and you should be okay:[/s]

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"

Very strange…

HTML Validator (Firefox extension) sees no error but the W3C stops on your doctype declaration as you quote it.
It seems that you use some kind of compression on your source but preserved tabs, what happens if you replace that tab into the declaration with a single space ?
I wouldn’t be surprised it validates…