VirtualHost not reading .htaccess?

Ok, this is weird. I was using separate directories and switching the main HTDOCS folder via MAMP every time I wanted to access a different site locally. Then I realized that I could use subdomains on localhost for multiple dev sites at one time. I setup the /etc/hosts file and the following structure in the Apache config:

<VirtualHost *>
   DocumentRoot "/the/path/to/files"
   ServerName server1.localhost
   AccessFileName .htaccess
   <Directory />
      Options			FollowSymLinks
      AllowOverride		None

It worked! The homepage loads great, until I realized that my mod_rewrites in my .htaccess file weren’t working. If I goto server1.localhost/something I get the Apache 404 error, where if I go to server1.localhost/index.php/something I get the proper CodeIgniter (PHP) 404. The .htaccess is the vanilla CodeIgniter file:

RewriteEngine on
RewriteCond $1 !^(index\\.php|images|robots\\.txt)

RewriteCond &#37;{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule ^(.*)$ /index.php/$1 [L]

Again, the redirect works fine using the main HTDOCS folder…it’s just something with the VirtualHost structure that’s goofing it up.

Any suggestions?



P.S. I’m assuming that because the VirtualHost is taking place at the Apache level, PHP doesn’t know whether it’s the main HTDOCS folder, or on a VirtualHost. That’s a correct assumption, right? It’s not as though something in the complexity of CodeIgniter could be screwing this up, because it doesn’t know the difference…?

You’re okay except for the NONE which should be ALL.

Of course, I’d whine about you using Options +MultiViews as that usually causes major problems (for me).