VERY weird message

I am using PHPMyAdmin to handle my database…and when I click in a table(from the directory tree on the left) to browse its contents I get the following message:

1146- Table '‘ users’ does not exist

it is very weird…the table is listed in the directory tree along with its columns

If I go to see its structure though in the main pane…no columns are listed there

If I refresh PHPMyAdmin the table is still listed in the directory tree but I still get the above message

I really cannot explain what is going on here.

Can you provide a little more detail on your db setup? or a PHPMyAdmin screenshot, if there’s nothing proprietary?

some things have occured in the meantime…in my attempt to solve the situation…

First of all I deleted the table…
And then tried to recreate it from a backup I have.

But the weird things continue…
When trying to recreate the table(with the exact same name)I get I message saying the table already exists…
After a search I made I found that the reason for the above might be an orphan idb file…which I deleted.

I then tried to recreate the table with the same name again(after deleting the IDB file).

Nonetheless,I still get the message that the table already exists.

I do not know what to do or assume.

That is likely the cause of your problems.

Tables should not be deleted, they should be DROP-ped.

IMHO mucking about in the database folders is not the best idea.

Have you tried a CHECK TABLE query?

or a REPAIR TABLE query?

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.