Vagrant up not working - 'laravel/homestead' could not be found

support
book

#1

Hi,

I have downloaded the virtual server 'Homestead Improved', and when I run the command 'vagrant up' the following message appears:

Bringing machine 'default' up with 'virtualbox' provider...
==> default: Box 'laravel/homestead' could not be found. Attempting to find and install...
    default: Box Provider: virtualbox
    default: Box Version: >= 1.0.0
The box 'laravel/homestead' could not be found or
could not be accessed in the remote catalog. If this is a private
box on HashiCorp's Atlas, please verify you're logged in via
`vagrant login`. Also, please double-check the name. The expanded
URL and error message are shown below:

URL: ["https://atlas.hashicorp.com/laravel/homestead"]
Error: The requested URL returned error: 404 Not Found

My OS is Linux Mint. From the book "PHP & MySQL: Novice to Ninja, 6th Edition" I also checked the 'Appendix B: Linux Troubleshooting', and I run the following command:

sudo ip link set vboxnet0 up sudo ip addr add 192.168.10.1/24 dev vboxnet0

Did't work either. This is what it says after I run the above command:

Error: either "dev" is duplicate, or "sudo" is a garbage.

If anyone can help I'd appreciate it. Thanks.


#2

Atlas became "Vagrant cloud" fairly recently. I'd assume that Vagrant needs to know about the new URL as https://atlas.hashicorp.com/laravel/homestead should be https://app.vagrantup.com/laravel/boxes/homestead after the rename. I'd have thought they'd have kept the old URLs available but it looks like it's not.

Firstly check your vagrant version by running vagrant --version and update it if possible. If your OS' repos don't have a newer version, there's a suggestion here: https://github.com/openebs/openebs/issues/191 for changing the URL


#3

Thank you. I changed the URL with export VAGRANT_SERVER_URL=https://app.vagrantup.com and it worked, but later it gave this error:

There was an error while executing `VBoxManage`, a CLI used by Vagrant
for controlling VirtualBox. The command and stderr is shown below.

Command: ["startvm", "fff970aa-ceaf-43a3-85e2-7b04c0886045", "--type", "headless"]

Stderr: VBoxManage: error: The virtual machine 'homestead_improved-master_default_1518122542742_75961' has terminated unexpectedly during startup with exit code 1 (0x1)
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component MachineWrap, interface IMachine

I tried it on windows 10 and everything worked fine.
Thanks a lot anyway.


#4

You can get more information about the error if you open virtual box, click the VM which was created and then press "show". It should give you a more meaningful error message.

There are also a few suggestions here: https://askubuntu.com/questions/217972/virtualbox-does-not-run-ns-error-failure


#5

Might I recommend this instead.

https://puphpet.com/

You can configure the box to whatever specs you need through a visual GUI. When I was doing php dev this was one of my goto secrets for standing up local dev environments. You can also easily modify the box without regressions as a project evolves and requires new technology. One of the great things about puphpet is installing php extensions is a breeze.


#6

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.