Upgrade php version in Dedicated Server

I am trying to upgrade php 5.1 to 5.2 in Linux Virtual Dedicated Server. BUT when I tried to “yum update” following error shows:

Config Error: File contains parsing errors: file://///etc/yum.repos.d/utterrambings.repo
[line 4]: /i386/

Should I delete it and install new one? If yes, how?


Probably. Here’s how to install that yum repo:

Yum Repository Setup Instructions | Utter Ramblings

If you’re gonna upgrade PHP, you should aim for a more current version than 5.2 too. The current stable version is 5.3.6; 5.2 is missing a lot of useful features and improvements.

Thanks Dan,

After reading the same doc I have tried to installed but I get mentioned error.

So now I am trying to install Atmoic Yum Repo but when I tried that error shows.

Can you suggest me how to upgrade 5.1.6 to 5.3.6?

Stop trying to do other stuff and fix the problem you have first.

You have a parse error in /etc/yum.repos.d/utterrambings.repo

So open up that file and replace its contents with what are supposed to be there, which is in the article.

If you can’t figure it out, then remove that repo altogether so yum stops trying to use it.

THEN you can either use it to upgrade PHP (if you fixed it), or use another repo (if you didn’t and removed it).

What OS distribution is this? It’s got yum, so some RedHat variety? For CentOS I only use epel/remi for getting packages newer than the RHEL repos.

What command I use for remove utterrambings.repo?

Using Linux OS distribution.

Delete the file, and remove its directory under /var/cache/yum/.

Linux is not your distribution. I am asking which Linux distribution you have.

Which distro you are using ? Like CentOS, fedora etc ??