<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Task function must be specified at Gulp.set - JavaScript - The SitePoint Forums</title>
    <meta name="description" content="hello 
I am trying to concatenate CSS Files; I am facing this problem when I am using this script 
(Please note that I have installed gulp and gulp-concat) 
This is my script 
var gulp = require(&amp;#39;gulp&amp;#39;);
var concat = req&amp;hellip;">
    <meta name="generator" content="Discourse 2.4.0.beta9 - https://github.com/discourse/discourse version 5e3fc31f2c13d335dc92c9dd684ff4c7fa254da9">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="http://www.sitepoint.com/community/t/task-function-must-be-specified-at-gulp-set/342573" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"http://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"http://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="http://www.sitepoint.com/community/opensearch.xml" title="The SitePoint Forums Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_bcd8a64cae58f8ccb067388c407fd7c57b76288e.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_2f3b67f14409e75c717bceb8560f3547599a3a49.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/3ea6ceedc3defc7b2344bb8ab6143c942dd5886a.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-f35b4da49411e6f5559073523aab983da483976a3954c79c756f8579f6fbd6ef.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-f35b4da49411e6f5559073523aab983da483976a3954c79c756f8579f6fbd6ef.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Task function must be specified at Gulp.set&#39;" href="https://www.sitepoint.com/community/t/task-function-must-be-specified-at-gulp-set/342573.rss" />
    <meta property="og:site_name" content="The SitePoint Forums" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="http://www.sitepoint.com/community/t/task-function-must-be-specified-at-gulp-set/342573/5" />
<meta name="twitter:url" content="http://www.sitepoint.com/community/t/task-function-must-be-specified-at-gulp-set/342573/5" />
<meta property="og:title" content="Task function must be specified at Gulp.set" />
<meta name="twitter:title" content="Task function must be specified at Gulp.set" />
<meta property="og:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta name="twitter:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta property="article:published_time" content="2020-01-21T22:28:55+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/f00b24c64d832481ce09a67edddad31db5dad44a.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="The SitePoint Forums" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <h1 class="crawler-topic-title">
    <a href="/community/t/task-function-must-be-specified-at-gulp-set/342573">Task function must be specified at Gulp.set</a>
  </h1>

  <div id='breadcrumbs'>
      <div id="breadcrumb-0" itemscope itemtype="http://data-vocabulary.org/Breadcrumb"
>
        <a href="/community/c/javascript" itemprop="url" class='badge-wrapper bullet'>
          <span class="badge-category-bg"></span>
          <span itemprop="title" class='category-title'>JavaScript</span>
        </a>
      </div>
  </div>

      <div class='crawler-tags-list' itemscope itemtype='http://schema.org/DiscussionForumPosting'>
          <div itemprop='keywords'>
            <a  href='http://www.sitepoint.com/community/tags/general-dev' rel="tag">
              <span itemprop='headline'>general-dev</span>
            </a>
          </div>
      </div>

  


    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='/community/u/ahmedchouihi'><span itemprop='name'>ahmedchouihi</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2019-10-22T11:57:45Z' class='post-time'>
                October 22, 2019, 11:57am
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>hello<br>
I am trying to concatenate CSS Files; I am facing this problem when I am using this script<br>
(Please note that I have installed gulp and gulp-concat)<br>
This is my script</p>
<pre><code class="lang-auto">var gulp = require('gulp');
var concat = require('gulp-concat');

gulp.task('default', function() {
});

gulp.task('css', function() {
    return gulp.src('css/*.css')
        .pipe(concat('concat.css'))
        .pipe(gulp.dest('css/dist'));
});

gulp.task('default', ['css']);
</code></pre>
<p>This is the error output</p>
<pre><code class="lang-auto">$ node filemerger.js
assert.js:42
  throw new errors.AssertionError({
  ^

AssertionError [ERR_ASSERTION]: Task function must be specified
    at Gulp.set [as _setTask] (C:\optimisation\linksandscripts\cssmerging2\node_
modules\undertaker\lib\set-task.js:10:3)
    at Gulp.task (C:\optimisation\linksandscripts\cssmerging2\node_modules\under
taker\lib\task.js:13:8)
    at Object.&lt;anonymous&gt; (C:\optimisation\linksandscripts\cssmerging2\filemerge
r.js:13:6)
    at Module._compile (module.js:653:30)
    at Object.Module._extensions..js (module.js:664:10)
    at Module.load (module.js:566:32)
    at tryModuleLoad (module.js:506:12)
    at Function.Module._load (module.js:498:3)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)

</code></pre>
<p>Thanks in advance</p>
        </div>

        <meta itemprop='headline' content='Task function must be specified at Gulp.set'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='/community/u/m_hutley'><span itemprop='name'>m_hutley</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2019-10-22T12:37:17Z' class='post-time'>
                October 22, 2019, 12:37pm
              </time>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><aside class="onebox whitelistedgeneric">
  <header class="source">
      <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/2/5/25b919dbff0bc07ac6de260c989dd22c7d84106e.png" class="site-icon" width="96" height="96">
      <a href="https://gulpjs.com/docs/en/api/task" target="_blank" rel="nofollow noopener">gulpjs.com</a>
  </header>
  <article class="onebox-body">
    <img src="" class="thumbnail">

<h3><a href="https://gulpjs.com/docs/en/api/task" target="_blank" rel="nofollow noopener">task() · gulp.js</a></h3>

<p>task()</p>


  </article>
  <div class="onebox-metadata">
    
    
  </div>
  <div style="clear: both"></div>
</aside>
<br>
says that task is not recommended and that you should be exporting instead.</p>
<p>That said.</p>
<p>It also seems like your last line is the culprit - <code>gulp.task('default', ['css']);</code> does not match a parameter set of that function. task() takes either (string, function) or (function), not (string, array).</p>
        </div>

        <meta itemprop='headline' content='Task function must be specified at Gulp.set'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

            <div class='crawler-linkback-list' itemscope itemtype='http://schema.org/ItemList'>
            </div>

    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='/community/u/ahmedchouihi'><span itemprop='name'>ahmedchouihi</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2019-10-22T13:51:32Z' class='post-time'>
                October 22, 2019,  1:51pm
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-post="1" data-topic="342573">
<div class="title">
<div class="quote-controls"></div>
<img alt width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/ahmedchouihi/40/77221_2.png" class="avatar"> ahmedchouihi:</div>
<blockquote>
<p>gulp.task(‘default’, [‘css’]);</p>
</blockquote>
</aside>
<p><a class="mention" href="/community/u/m_hutley">@m_hutley</a> which function do you mean? How can I replace this line I mean<br>
Thanks in advance</p>
        </div>

        <meta itemprop='headline' content='Task function must be specified at Gulp.set'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='/community/u/RyanReese'><span itemprop='name'>RyanReese</span></a>
            
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2019-10-22T15:28:43Z' class='post-time'>
                October 22, 2019,  3:28pm
              </time>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>You have no function defined on your last task. I think <a class="mention" href="/community/u/m_hutley">@m_hutley</a> is right…</p>
<pre><code class="lang-auto">gulp.task('default', ['css'], function() {
 // empty function
});</code></pre>
        </div>

        <meta itemprop='headline' content='Task function must be specified at Gulp.set'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>
    <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='/community/u/system'><span itemprop='name'>system</span></a>
            
              closed 
          </span>

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-01-21T22:28:55Z' class='post-time'>
                January 21, 2020, 10:28pm
              </time>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.</p>
        </div>

        <meta itemprop='headline' content='Task function must be specified at Gulp.set'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>


    </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav' itemscope itemtype='http://schema.org/SiteNavigationElement'>
        <ul>
        <li itemprop="name"><a href='/community/' itemprop="url">Home </a></li>
        <li itemprop="name"><a href='/community/categories' itemprop="url">Categories </a></li>
        <li itemprop="name"><a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a></li>
        <li itemprop="name"><a href='/community/tos' itemprop="url">Terms of Service </a></li>
        <li itemprop="name"><a href='/community/privacy' itemprop="url">Privacy Policy </a></li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div class="proper-ad-unit ad-sticky">
   <div id="proper-ad-sitepoint_main_1">
       
    </div>
</div>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/6eb9df8882b2f1244b8786b2692d281653a9fcfb.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
