Syntax Error in Script after upgrading site from jQuery 1.7.2 to 1.8.3

Hello all,

I upgraded our WordPress site today and now it looks like I’ve broken the functionality of our main form. DOH!

Our site is

The form on the side is supposed to take you through steps 1 through 5 before sending you to the “/schools” page. However, since the upgrade, the form skips straight from Step1 to the schools page. As far as I can tell, the newer jQuery version (1.8.3) doesn’t play nice with our custom script. The script worked fine before the upgrade, when the site used jQuery 1.7.2.

In my feeble attempt to figure out what was going on, I turned on WP’s debugging mode. I was able to get this message:

Uncaught Error: Syntax error, unrecognized expression: #step-1 input[‘radio’].required

That error showed up on my debugging console only for a split second after clicking the ‘Next’ button, and before being taken to the schools page. The problem is, I’m not sure how to fix.

I’d really appreciate any help.

Thanks in advance!

Instead of

#step-1 input['radio'].required


#step-1 input:radio.required


Many thanks for your speedy reply. Your solution worked perfectly!


No problem, glad to help