Slider getting stuck only in Chrome


Here is Mysite.

Having an issue which so far I think is only affecting Chrome (have not tested IE yet, but FF and Safari seem fine). If anyone could confirm IE issues that would be appreciated.

Basically the second slide gets stuck on first load. If you refresh or manually move the slider along it’s then fine after. I’ve checked it loads of times - cleared cache - and it happens.

I have the same slider running on the portfolio pages without any problems.

I also have some other JS running on the portfolio page so wondering if that is causing an issue?

The site is running on the latest version of Wordpress 3.2.1.

The slider is the latest version of NIVO slider v 2.6.

Here is the code for the page:

homepage.php -

and the header:

header.php -

Really would appreciate any help as this has the Wordpress guys stumped!



Thanks both for pointing out the error and that it is happening your side also.

I thought maybe the error is thrown up from that script as I haven’t tweeted yet. Just posted a tweet and the slider seems to be working fine right now :confused:

Not sure if that has solved it (or why it should solve it for that matter). I’m also on Mac Ralph.

Out of interest what do you use to check the Javascript?


Ah, as I type and check it’s still doing it… :x

There are developer tools for most browsers. You can either download the Firebug add-on for Firefox and also the Firefox developer tools (the best option, I find) or use the inbuilt developer tools in Chrome, Safari etc.

I can confirm that behavior in Chrome (Mac), but I don’t understand the error messages being thrown (pretty much what John showed).

First thing I’m noticing is a JS error from a different script (blogger.js):

document.getElementById("twitter_update_list") is null
at line 9 - blogger.js:  document.getElementById('twitter_update_list').innerHTML = statusHTML; 

Not sure if this is what’s causing your problem, I can’t seem to replicate it here on Chrome (Win + Mac) or Firefox

Have you tried removing the twitter js? It’s worth removing it to see if it’s getting in the way, and if so, you could try something different.

Thanks Ralph.

Well, been having another stab at this and found the following out…

When I type the full url into Chrome address bar, the page loads and the slider pauses on the second slide.

But when I type just go 9 cretive into google search on Chrome and access the page through the search rank, the page loads and the slider works fine.

As above I clear the cache before each test.

I’m just not sure what this points to right now. Maybe the above info can highlight the problem to someone hopefully.

Not sure if the problem is JS related or not now!


Chrome has some really great dev tools that could probably show you where the JS is getting stuck. Unfortunately, I’m not totally sure how to use them yet. But here’s a great video I stumbled on just the other day:

A Re-introduction to the Chrome Developer Tools « Paul Irish

Sorry yes I tried removing the blogger.js script but no joy.

Just tried another test where I typed in the url of another page within the site with the slider (portfolio/case1). Same thing happened with the second slide sticking. So it seems on first load the slider will act in the same way on any page.

Tried removing the colour fade script in the header to see if that was conflicting but no change either.