Site not indexed. Its been 2 weeks now

Hi All,

We started the site almost 2 weeks ago now and submitted it via Google Webmaster tools to Google.

We have been checking to see if it has been listed.

Unfortunately even after 2 weeks, I observe the same thing when I Google for the website using the search term “ 
A description for this result is not available because of this site's robots.txt – learn more.

Can anyone let me know why this is happening as my robots.txt is allowing the indexing of the site;

User-agent: *
Allow: /
Disallow: /case.html


I don’t know where you’ve been looking, but it’s there now!

I think you are looking at the wrong site @Stevie_D ; or have not seen the part about the robots.txt.

Have you tried removing your robots.txt Hemanth ?

I am looking for it on

@Rubble: No I haven’t. Will that help and is it ok not to have robots.txt at all?

[font=calibri]Nope, I’m still in the dark as to what the problem is. When I search for, I get the following result:

The text used in the description is the same as what is given by the <meta description> on that page, which to me sounds like everything is working fine. What have I missed?[/font]

I see what is different @Stevie_D ; if you do not use the site: you get different results from Google and that is what the OP and I were looking at.

I would try removing the disallow: case.html and see what happens after a few days.

Please do recheck it which is working fine might be you checking in wrong methods

Ah, I see. The point remains that the site IS indexed, and Google does have the correct information in some parts of its index, which usually means it’s just a matter of time until the mistakes are corrected.

I have removed the robots.txt file now.

Its been 2 days since the removal.

But when I search for “” in, it still shows up the same result;

you can try to use the default robots.txt

User-agent: *
Allow: /

Since you site is already index.

A site is indexed when you type in the search engine site: (yoursite).com and your main webpage and its subpages appears in the results.

What I’m getting here is that you added your site in the webmaster tool and you haven’t seen your pages getting indexed or something.

Have you followed the steps to adding your site in the tool? Like uploading that file, which the tool provides, to the root of your domain? You can do this via cpanel or whatever that is your are using.

You then have wait for a day or two for the webmaster to crawl into your site and its pages.

I deleted the robots.txt file and waited for 2 days.

I then added a new robots.txt file and Google finally picked it up.

God knows why the delay but now its all fine.

Thank you all…