Safari mac won't show cursor pointer

It’s a anchor. Position absolute with a position left and top. And a height and width. With a higher z-index. It just shows the arrow when hovering over it. Any ran across this?

Applying cursor pointer does not fix it. The only thing I found that fixed it was removing position absolute. But cant do that.

Is this ONLY Safari Mac? Does Chrome/FF Mac also exhibit this? Do you have an online website?

Edit-Clear your cache on Safari Mac, and restart your computer, first and foremost. If your website isn’t online, please give us your FULL reduced test page so we can replicate it.

I see no problems in Safari mac using the code you mentioned so as Ryan said we will need to see what you are using.

Sounds like a z-index/stacking content issue to me.

Ok finally figured out why. But still cant find a fix. The links are positioned over the object tag (flash menu). I tried changing wmode from opaque to transparent to window but no change. Other browsers show the cursor hand. Any tricks to that?

Here is the page Its the Blog and FAQs link on the top and bottom of the menu on left. And I assume only mac. I haven’t tested on windows yet.


I make the wmode transparent and give the FAQ/Blog a 9999 index (obviously higher than needed) and I see a cursor showing. Just on browserstack though so hopefully it works for your local setup.

Good seeing you again Eric. Didn’t know that was you until I visited your website.

FYI Safari Windows did not have this issue.

Thanks Ryan you too :slight_smile: I just spent the last year building a site so my web design blood got flowing a little bit.

I tried that again to make sure but doesn’t fix it on my end. Still only shows a arrow - not a pointer. Anybody know any tricks for this?

I didn’t beleive its a stacking issue or the link would not work.

Weird. It’s showing as working on browserstack. I’m sure this won’t make a difference but I think I might have forgotten to tell you to add display:block; on the <object>. Again, probably won’t make a difference.

Either way, that entire setup there is a flash element aside from FAQ/Blog. Would it be unfeasible to include the FAQ/Blog in that flash as well? Not a fix but a workaround?

tried block no go. Ya if I new anything about flash. but I dont. Tried js too. no go.

It’s weird, in Safari I get the link glove sometimes and other times just an arrow.

If I click off the flash (just on the background) I get a glove, then if I move my mouse around the flash over the background (body) and goto the other link it is still a glove, if however I go from the link (with a glove) straight up the column to the top link it is an arrow. Clicking on the body again changes it back to a glove. Maybe this can lead someone smarter than I am to a solution. Seems like a z-index. issue to me too.

If all else fails, do you have the flash file .fla (are they still called this?) LOL ? It has been a number of years, but I could add the links to the flash file for you. Or at least give it a try. :smile:

1 Like

A couple things I have found. If you add pointer-events:none; to the object the pointer shows again on the links but the flash no longer works. If the links are visually on top of the object tag they won’t point. As soon as you drag it off the flash they point again. Aside from editing the flash (don’t have the fla) I cant find a fix.

On my machine there is no pointer regardless of how I entered or exited. Only the arrow. It makes no sense. Where it’s positioned in the html should say everything to do with if its clickable or not and etc. Not only visually.

I can live with it as its only a small subset of users and not critical. But I would like it fixed. Most prob wouldn’t even notice. But I do. And it bugs me.

I’ve tried dragin the anchor over it. I’m going to try position relative on the object and drag it over. Somehow we have to trick safari into thinking the links are not visually over the flash.

Try placing a span inside of each anchor - make sure that span has position:relative

Edit-Worked on BStack - just loaded it up again to see if it still works and now it’s not working. Hate how buggy this is.

Change the anchors to display:inline-block and not block…Worked twice now in BStack.

Nope span did not work. Thanks though. Interesting… if I positin relative the object and drag it over 300px to the right then drag the anchor over too then the pointer shows up again. No idea what it’s doing?

What about 1px? How far over until it starts to show? Is it a gradual process? I’m curious

It might be Content that makes it show for some reason if you drag it 300px over. The only real difference is that Content has position:relative, whereas #left does not. Try adding htat.

The span? I tried relative and absolute. Disolay block and height 30px with a background color and z index and cursor pointer and every combo in between

I have a stripped test page here. Though as of now for some odd reason I can’t get the flash to show up.

No ignoring the spans for now…Just the basic anchors…you mentioned the anchors you put 300px and it started working. What does 150 do? Is it something about being “inside” of Content that it starts to show? As you go lower in value, does half the anchor show the pointer and half not? Does it gradually work? I’m curious if the parent #left needs position:relative

I’m not curious about a test page right now aside from your live one. lol

<!--[if !IE]>-->
			<object type="application/x-shockwave-flash" data="aboutus.swf" width="250" height="400">
			<param name="wmode" value="opaque">

Your conditional comments are wrong.

Fix them Also, why do you nest objects (one for IE?) I think that might be related to the issue. Remove the nesting, fix your conditional comment (display:none the non-IE object for IE if you need to). Right now, the live pages are displaying hte nested flash. So when you removed that from the test page, it’s not showing.

Edit-I really need to take lunch ugh