Rewrite URLs in Zend server

Hi All,

I have ZendServer installed on win7 with :

_SERVER["SERVER_SOFTWARE"]	Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/0.9.8o


PHP Version 5.3.9-ZS5.6.0

I have this .htaccess in the root of a website :

RewriteEngine on

RewriteCond %{REQUEST_URI} business
RewriteRule ^([a-zA-Z_]+)$ index.php?p=$1 [L]

which was working OK @ my old webserver (Apache but NO Zend).
I’ve searched some forums and according to the ‘most common’ solution/advice I changed

AllowOverride None

INTO this :

AllowOverride All

in Zend/Apache2/conf/httpd.conf file. File saved, PHP restarted but the url rewrite still doesn’t work (I got Not Found message).
Any help will be highly appreciated!!!

Welcome back!

Zend server, eh? That’s a new one on me, however, if it uses Apache2 as shown, let me ask whether you’re running on a WinDoze box or a 'Nix box BECAUSE your path looks like WinDoze whereas 'Nix’s configuration file is known as Apache2.conf which should have

<Directory />
    Options FollowSymLinks
    AllowOverride All

Both are required.

Looking at my tutorial article, too, are you sure that mod_rewrite’s been enabled (comment # removed)?



Thank you David for trying to help me!
At the moment this issue is not so important - in the meantime some other stuff came in so I gave up to configure the URL redirect on Zend server. Thanks anyway and sorry for wasting your time… :slight_smile:

No worries!

You know how to get a hold of me when you need help (thread/PM/Skype) so I’ll be available when you need me.