Problem after server upgrade

After sometime, back in sitepoint.
My host used now …Apache 2.x, PHP 4.x and 5.x with suPHP enabled after last upgrade.

My moodrewrite script is

AddType application/x-httpd-php5 .php .htm .html

Options +FollowSymLinks
RewriteEngine on
RewriteRule A(.*)\A$ /classifieds/detail.php?id=$1
Options +FollowSymLinks

But still It does not work, what is the wrong with this script?

First please check if you .htaccess file work or not.

Thank you,
this script work early.
As I heard today they use suPHP, that can be the problem.

Yeah I head so too, I haven’t worked on suPHP much so didn’t know. :slight_smile:

that .htaccess file looks fine to me. I’d say there is some configuration error in the host. As far as I know using suPHP shouldn’t matter; .htaccess files are Apache only, PHP’s got nothing to do with it.

ScallioXTX, thank you for clarification. I will contact host again.

I just want to up data about this issue

My host has change my script
RewriteRule A(.)\A$ /classifieds/detail.php?id=$1
RewriteRule A(.
)A$ /classifieds/detail.php?id=$1

Now it is working, they say it was the problem, but as I remember that was the script worked for years.
I am confused…:mad::mad:

It looks like you might have been “escaping” (telling the regex engine to take it litterally) the last A, which you don’t really have to but it shouldn’t hurt.
So I’m not too sure why it’s solved either, but let’s be glad it is [solved] :slight_smile: