Prettier formater doesn't work?

Hi all I hope that I am on right place.My prettier doesn’t work at all I have done all necessarily config to work but it won’t.


Someone has same issue?

Hi,

Not really. From your screenshots, it’s not 100% obvious (to me at least) what you are trying to do and what is not working.

Perhaps you could rephrase your question and add a couple more details. It would be helpful if you could let us know what you have tried, what you expected to happen and what actually happened.

FWIW, I use Prettier with VSCodium (VS Code minus telemetry) on Linux and it was relatively straightforward to setup. I’m sure we’ll be able to get to the bottom of what is not working for you.

Okay I want to enable prettier code formatter, as you can see from screenshots I set default formatter to prettier, format on save and I enable it in json, but it still won’t work, it won’t format code and I don’t know what to do I think my settings are fine

Ok, well assuming you have the Prettier extension installed, from within VS Code make a new file. Select JavaScript as the language, then copy paste this code into the new file:

function Entrar(){

    if (confirm("Foto No Actualizada, se subira sin actualizar")) {
     document.fm1.submit();   
     return false; 
     
    } 
    
     
     document.fm1.submit();   
    
    } 

Then hit Ctrl + Shift + P and type “format” (without the quotes) into the command palette (search box).

You should see an option Format Document. Click that.

If it is the first time you are running this command, you may then be prompted to choose which formatter to use. In this case, click the Configure button and choose Prettier - Code Formatter.

If everything went as expected, the code should now be nicely formatted.

What happens when you do all of the above?

1 Like