Plugin/taxonomy issue. Not displaying the page once called

Hi, I created a plugin. it works…half way. The plugin allows for three different types of posts & taxonomies.
for example critters and characters.

The category “critters” or tag "crazypede " does display appropriatly. but when clicked it brings up a 404. = should work but gives a 404 = this shows.

I have tried to deactivate/reactivate the plugin. Tried saving the permalink choice again.
Not sure where to fix my code so that wp understands to pull up

The code for the plugin is

	//Critters post types
	$labels = array(
		'name'               => 'Critters',
		'singular_name'      => 'Critter',
		'menu_name'          => 'Critters',
		'name_admin_bar'     => 'Critter',
		'add_new'            => 'Add New Critter',
		'add_new_item'       => 'Add Critter',
		'new_item'           => 'New Critter',
		'edit_item'          => 'Edit Critter',
		'view_item'          => 'View Critter',
		'all_items'          => 'All Critters',
		'search_items'       => 'Search Critters',
		'parent_item_colon'  => 'Parent Critter:',
		'not_found'          => 'No Critters found.',
		'not_found_in_trash' => 'No Critters found in Trash',

	$args = array(
		'labels'             => $labels,		        
		'public'             => true,
		'publicly_queryable' => true,
		'show_ui'            => true,
		'show_in_menu'       => true,
		'menu_position'      => 5,
		'menu_icon'      	 => 'dashicons-star-filled',
		'query_var'          => true,
		'rewrite'            => array( 'slug' => 'critters' ),
		'capability_type'    => 'post',
		'has_archive'        => true,
		'hierarchical'       => false,
		'supports'           => array( 'title', 'editor', 'author', 'thumbnail', 'excerpt', 'comments', 'custom_fields' ),
		'taxonomies'		 => array('category','post_tag')
	register_post_type('critters', $args);

Also I created a taxonomy.php it should automatically show these posts but instead it looks like the archive.php is still being used instead.

And just to clarify. I basically would like for the user to not get a 404. But to be taken to that category or tag.

Sighhh. Sad day when the gurus and wizards of sitepoint do not know…:cry:

I am hoping that maybe you just didn’t see this post. Can you give me your opinion on this?

the tags and categories created by the taxonomy are populated but give me a 404 when i click on them. Have you run across this? Is it the rewrite?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.