Pls help to remove this box

folks, a box appearing around my image. whats wrong:)

Putting img { border: 0 } in your stylesheet.

The box appears because you have used an image for a link. The box is the browsers way of letting the user know that they can click on it, and the browser uses the border color to indicate whether they have visited the linked-to page or not.

One way to deal with this is to remove the border from all links, which may not be a good idea if you use them for other types of image links on the page.

Another way to deal with this is to consider what types of images you will want to have the border shown, and the ones you do not. it’s better not to completely disable one feature, if you’ll need it in other places such as added decorative borders to normal images.

If it’s only menu navigation buttons and command buttons, you may wish to disable only those


#nav a img, a img.command { border: none; }

And if you don’t want any linked images to show their border, use:


a img { border: none; }

Thank you folks,
let me try your suggession and feedback :slight_smile:

You can also put it in the HTML code, adding a border=“0” attribute to the IMG tag.

Which is not a good idea, as such a presentational aspect of things belongs in the stylesheet, not inlined with the content.

Not only is this not a good idea, as Paul notes, it’s deprecated to boot.