I am trying to install phpMyAdmin. I got this error:

phpMyAdmin - Error

The mysqli extension is missing. Please check your PHP configuration. <a href=“Documentation.html#faqmysql” target=“documentation”><img class=“icon” src=“./themes/pmahomme/img/b_help.png” width=“11” height=“11” alt=“Documentation” title=“Documentation” /></a>

Can someone help with this???


Are you running this on your own server? If so, check php.ini for the mysqli extension entry (which is probably commented out with a # in front of it). Uncomment it, and restart apache (just to make sure it sticks)

The line you are looking for in php.ini is:


Save file. Restart Apache.

If for some reason you can’t do this, you can edit phpMyAdmin’s file and change it to use the php_mysql.dll (no i) extension.

I checked php.ini and the line is uncommented. What else should I check for???


Do you really need phpmyadmin? It’s quite heavy tool for basic mysql… My favourite is Adminer, it’s only one file to upload and no installation needed. You should try it out…
Regarding your problem, I think the problem is in PhpMyAdmin basic settings. Is there a line about Mysqi? I don’t think it’s required