PHPMyAdmin question

Hopefully this post is in the right place. If not, please forgive me.

I’m trying to import a db using myphpadmin and I’m getting the same error over and over.

You probably tried to upload too large file. Please refer to documentation for ways to workaround this limit.

I’ve looked at the documentation, and made the recommended changes, but I still run in to the same issue. The db isn’t that big (28 MB) and I’m beginning to wonder if it’s a permissions level issue on this PC? Do I need to have root access on my PC to be able to do this? I’m part of the admin group, but I believe there is a higher-level admin/super-user type account set up. Could this be my problem?

Thanks in advance.

Are you doing this locally?

Skip phpMyAdmin and import the file directly with mysql.

prompt> mysql -uusername -ppassword dbname < file.sql

Dan - thanks for the tip. I’ll give it another shot. I may just not be running that command correctly from the command prompt.

BTW - do I need an aboslute path back to the root, or can I use something other than an absolute path?

A relative path to the current working directory works fine

Hey Dan - thanks again for the help. I’m having trouble using the command prompt. I’m being told that a file by that name can’t be found. It’s not making any sense at all. I know that the path is correct, and the file name is correct after checking several times. Do you have any other advice?

edited to add - this is a local desktop install (running XP Pro) ; I just wanted to make sure I was clear on that

To run a program from the command prompt, either:

  1. The program is in the current working directory. If your prompt says “c:\Documents and Settings\Orracle\ >”, then the program would have to be in that directory.

  2. The program is in your PATH. This is a system variable, that you edit from Control Panel (System > Performance? > Environment Variables? … haven’t used XP in 5 years). The PATH variable specifies where the command prompt should look for commands you type, aside from the current directory.

So either:

  1. Edit your PATH to include the directory of the mysql program

  2. Change directory to the directory of the mysql program (cd c:\some\dir\here)

then run it.

Dan - thanks for all of your input. It’s still not working - either through the command prompt, or through phpmyadmin. I have full admin rights on this computer, and I’ve mapped specifically from and to that directory where mysql is contained. I’m obviuosly doing something wrong on my side.

Here is what it looks like:


C:\\ -uDBusername -pDBpassword dbname < C:\\wamp\\bin\\mysql\\mysql5.0.51a\\dbname.sql

'C:\\wamp\\bin\\mysql\\mysql5.0.51a is not recognized as an internal or external command, operable program, or batch file.'


I’ve made sure that the path is correct for the program as well. If I try to do it through phpmyadmin I get the same error as previously mentioned. I’m at a total loss at this point.

C:\>mysql -uDBusername -pDBpassword DBname < C:\wamp\bin\mysql\mysql5.0.51a\DBname.sql

that’s what I actually used

You forgot to start the command with the program you want to run, “mysql”

-u, -p, these are command line arguments for the mysql command, they aren’t commands themselves

Sorry - I’ve got so many lines in this thing now that I forgot to put that part in - I did actually include it in the original command and got the same error.