Newbie question: WAMP setup error

Hi. I hope that this is the right place for this question. I’ve just installed WAMP so that I can try out a CMS for the first time, but it isn’t working. If I click on phpmyadmin, I get an error message about MySQL that states:

#2002 - The server is not responding (or the local MySQL server’s socket is not correctly configured)

I don’t understand this. Nor do I have a clue about how to fix it or where to go for an explanation that would be at my level. I only know that whatever is wrong here is also stopping any CMS from being installed.

The WAMP icon in the system tray appears to show that the services that it starts have indeed started. Is there some diagnostic page that I should look at (and give the results here)?

Can no-one help with this?

From memory I believe this has to do with the windows hosts file located in C:/Windows/System 32/drivers/etc/

You will need to make you open the file with a text editor running as an administrator, when you have it open add the following on a new line after the current contents of the file. localhost

That should fix it.

  • Sent from my iPhone using Tapatalk

Thanks for responding. I have just checked the file that you mentioned and it already has that entry at the end.

Is your MySQL server running? In xampp anyway it’s a windows service that you can set to start when the computer boots, or start manually later on.

At the bottom right of the task bar, where some running apps have their icons, if you have got WAMP running there should be an icon there. Assuming it’s running, left click on its icon and click “Start all services”

As I mentioned, the icon appears to indicate that all services were started (it’s green). I tried stopping and restarting them as well, but no luck.

Which version of WAMP are you using and what version of windows?

Windows XP. I can’t answer the first part of your question, though: there seemed only to be one version, I think. In the Start menu, it’s just called WampServer.

If you right click on the WAMP icon you will an about menu option, click that and it will tell you the version number. Try the the following just to ensure your MySQL server is running correctly.

Left click the WAMP icon and from the MySQL menu click MySQL console and for the password just hit enter. If it passes to another screen then the server is running normally, next type \s which will return the status of the server. Check to ensure the port number it returns is the default 3306 port.

To exit the command prompt simply type \q

There is at least 2 versions of WAMP that have been released, I’m using version 2. Is the version that your using called “WAMP5”? WAMP5 I believe can be thought of as version 1.

There’s a graphic on WAMP’s menu that shows describes it as version 2.1. (It was only downloaded a few days ago, so it should be up to date in any case.)

Sgt Legend: I just went through the menu option that you outlined, got a small black window up, pressed Enter… and the computer beeped (from the tower itself, I mean) and the black window immediately closed.

wow, never of the command prompt ever beeping before upon pressing enter. What i would recommend you try is uninstall WAMP completely including deleting the WAMP folder then restart your PC to ensure the services stop and re-install. If that doesn’t work the next thing we can do is check what applications your running so we can ensure there are no conflicts.

PS: Make sure to backup any data you need from your WAMP folder as it will be deleted when you uninstall it.

OK. I’ve gone through a thorough re-installation… Still not working, though.

Thanks for your help so far, chaps.

Before you installed WAMP had you previously installed an older version of WAMP or had separate installs of Apache, MySQL or PHP.

None at all.

You may want to get familiar with the mysql command line programs. If you can connect from the cli mysql program but not from phpmyadmin, perhaps your problem is really in the phpmyadmin configuration somewhere and not with the mysql server itself.

I am assuming wamp installs the cli mysql programs.

Belatedly fixed after much head-scratching and total guesswork. I have to turn off the firewall whenever I want to run WAMP.

Far from ideal, but at least it runs. Just need to work out how to use it now.