MySQL Root Password setting

I am following the instructions in “PHP & MYSQL Novice to Ninja” page 10, setting up MySQL and the root password. I have been able to successfully set the root password as per the instructions with both the MySQL Admin and phpMyAdmin showing as secure in the XAMPP security window.

I have restarted the MySQL service, but when I attempt to login via the “http://localhost/phpMyAdmin” page using “root” as the user and my new password, I get error 1045 Cannot log into MySQL Server

I have looked at the other posts similar to this topic, but they seem to address client PC’s connecting to a server, where I have the server on my local PC.

In PHPMyAdmin’s folder there is a file called “” did you change the values for user and password in that file?

Hi, Thanks for the reply.

No I hadn’t, as I didn’t know about this from the book. However I have now done so, setting the password value to my new password. I stopped and started MySQL service, and tried to login again, but still the same error message.

Have you tried to connect to the database using the prompt window? Because if it works there, then the password is correct and it must be some config file

I have tried from the XAMPP Control Panel, clicking on the Admin button gives me the login screen in IE. Is this the prompt window you are referring to?

Thanks all whom attempted to help with this issue.

I have resolved it by simply uninstalling XAMPP altogether, then re-installing. Followed the same set of procedures as in the book and all works fine. Go figure.


1 Like

Glad that you did. Just so you know, when I said the prompt window, I was referring to the command window, outside of XAMP or anything related to :wink:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.