Month with doctrine2

I’ve added Month.php intact in Doctrine\ORM\DoctrineExtensions\Query\Mysql folder then this in bootstrap:
$config->addCustomDatetimeFunction(‘MONTH’, ‘Doctrine\ORM\DoctrineExtensions\Query\Mysql\Month’);

I run this:
$query = $em->createQuery(“SELECT c.username FROM Entities\Client c WHERE MONTH(c.joinDate) = 10”);
$search = $query->getArrayResult();

Then get this with EchoSQLLogger:
SELECT p0_.username AS username0 FROM clients p0_ WHERE MONTH(p0_.join_date) = 10

since I get no error, I believe the class is loaded and function is called, but I get an empty array result. I did check join_date timestamp, and there are some rows for month 10. Did I do a mistake or their extension is no longer compatible with 2.4?

If the extension was not working then dql would have complained. Copy/paste the generated sql into a mysql console and make sure the query returns some results. It could be a timestamp issue.

Got it thanks, is here someome who appear to have from_unixtime (NOT unix_timestamp) doctrine extension who would share it with me?
I tried to write one but I get:
Error: Expected Doctrine\ORM\Query\Lexer::T_CLOSE_PARENTHESIS, got ‘=’

                $this->date = $parser->ArithmeticPrimary();