Major Problems with phpMyAdmin

Hello all,

I have PHP 5.2.12, MySQL 5.1.41 and Apache 2.2.14 installed on my Windows 7 machine all working fine. I have decided to install phpMyAdmin (3.2.5) to administer my databases. As it has been a long time since I’ve installed it, I thought I’d use my SitePoint PHP/MySQL book to guide me through this simple process - no problem. Loaded up http://localhost/phpMyAdmin, got the usual mcrypt error message, and proceeded to login with my root username and password (which are definitely correct).

Now the problem is that once I login with these credentials, the browser loads http://localhost/phpMyAdmin/index.php?token=XXXXXXXXXXXXXXXXXXXX

and subsequently loads a completely blank page (in Firefox). I thought I’d try this in my other browsers and the results were:

[]IE displays the usual ‘Internet Explorer cannot display the webpage’ error message.
]Opera displays a completely blank page.
[]Chrome displays the error message; ‘The web page at null might be temporarily down or it may have moved permanently to a new web address.’
[/LIST]displays the message; ‘Safari can’t open the page “http://localhost/phpmyadmin/index.php…” because the server unexpectedly dropped the connection. This sometimes occurs when the server is busy. Wait for a few minutes, and then try again.’

I have tried installed a previous version of phpMyAdmin (2) but same thing happens.

Any suggestons?

Much appreciated.

try HeidiSQL or the MySQL Query Browser instead of phpmyadmin

Also, this thread belongs in the MySQL section, not the general database section. There’s a whole part of the forum exclusively for MySQL. Can’t you look before posting?


I really hope that was tongue in cheek.

HeidiSQL looks a nice alternative, may have to give it a try if all else fails. I am used to phpMyAdmin and have used it many times for various projects, just seems like there is something in the configuration somewhere that’s tripping it up.

No, it wasn’t.


it was, however, quite unbecoming

Make sure that error reporting is enabled in php.ini as there could be a php error

Just had a go, it seems like it cannot load the MySQL extension! Will have a play see if I can see where that’s gone wrong.

Well first I apologise for putting this in the Database section rather than the MySQL section, I’m sure there’ll be a lot of sleep lost over that. Second, instead of a comment like that, how about just reporting the post in order for it to be moved? I’ve been round here longer than you think so don’t let my post count think otherwise.

Actually the php forum would be a more appropriate choice as phpmyadmin is a php app.

I’m certainly not having much luck, now seems that PHP cannot even locate the MySQL extension at all! I have extension = php_mysqli.dll unchecked in the php.ini file, can’t think of any reason why they’re not linking to each other.

Download xampplite, install it.
Everything will then work
(it is a preconfigured apache-php-mysql setup, with a few other bits such as phpmyadmin, for luck). If you wish to text send emails via a php page, yo uhave to configure the php and apache files to point at your real smtp server.