Lpad in views

Hi, I’m having a little silly difficulty here.

	  LPAD(`Tickets`.`Row`,2,'00') AS `Row`
  FROM (`Tickets`)

If I run this as a query I get the expected results (01,02,03,04,05,06…)

However the same thing as a view:

Create View `blarg` AS
	  LPAD(`Tickets`.`Row`,2,'00') AS `Row`
  FROM (`Tickets`)

I get this result
0x3238 all the way down my table.

I’m assuming I need to convert this number in order for it to work, any ideas?

can you show the code where this is happening, please

Ok finally found it.
It is suppose to happen automatically, and the sql program I am using isn’t creating the tables like it says it is.
What are your thoughts on this quote I found:

ZEROFILL is a pretty esoteric feature, supported by no other database server besides
MySQL. My recommendation is avoid using it.

Instead pass the input data through LPAD(), where you can pad with zeroes (or
anything else), which will also change the numerical data into a string. This
preserves the zeros when data hits the database layer (Zeos) in HeidiSQL.

why not just create your data type as ZEROFILL?

I consult the manual and google. I was able to do it with the zerofill suggestion. Only that concating a zerofill does the same thing as lpad. 0x00:(

So I’m back to square one

Did you bother to consult the manual?

I’ve tried to look up how to display the zerofill literally ‘display zerofill mysql’ in google and I didn’t find anything that was a clear cut answer, I just find a description of the zerofill but not how to handle it. Any suggestions?

Look up ZEROFILL and find out.

how would I get it to display the zeros?

I need them because I am using concat to put two values together but I want to make sure that they keep their number places