Issues with connecting to website after migrating to new server

I am uncertain if this is the correct category to post this, but I’m not sure where else to post it. I am experiencing an incredibly frustrating issue, and all Google searches have failed me as to how to resolve it.

2 days ago I changed the shared hosting, web host for my website. I moved from BlueHost to A2 Hosting. About 4 hours later after I registered the DNS changes, I was then able to access my website on the new host. I made a small change on the home page to make it easy to recognize if the home page being seen is from the new server or the old one.

I was accessing the new site fine for a few hours, but then suddenly my browser appeared to be targeting the page at BlueHost again. I tried multiple computers, devices and browsers, and all seemed to be targeting the BlueHost server. I tried multiple ways to clear browser cache including flushing the dns in ipconfig and flushing socketpools in Chrome. None of these things fixed this. What I did confirm, is that if I used my ISP to connect, then this issue remained. However, when I switched my cell phone to using my data plan, then I was able to connect to the new site, but if I switched to my WiFi, then I was again accessing my site at BlueHost.

I ran a traceroute and it showed that I was connecting to the BlueHost server.

I then rebooted my modem and router, and this resolved the issue. The site on A2 was again accessible to me. To my understanding either the modem or router cache was holding the DNS info for my old server?

For about 2 hours I was able to access the new site fine, but then once again it started to target the old site. I rebooted the modem and router, and this was again fixed.

I have repeated this process about 4 times now. The reboot works everytime, but only lasts for about 2 hours.

Does anyone know what is going on with this? Neither my web host or my ISP can think of what would be causing this issue.

All of this is way beyond my knowledge level, but somehow the DNS information from my old server is getting into my modem or router cache?

I don’t believe this is currently related to the DNS propagation, as it has pretty much completed the process:

Likely true. During the transition period, most service providers will overlap the site availability to ensure that the site isnt unnecessarily offline to people who get stale DNS results.

Not sure why it would happen repeatedly… I can understand the ISP’s DNS information/caching being stale and needing to update, but once that occurs i would think it would be stable on the new server. At most, it should happen twice unless there is some great instability.

For what it’s worth, my DNS hit on your address, when reversed, comes back to an A2 server. shrug

To help me readily notice if I was on the new or old server, I added “(2023”) on the title line of the website, so the new home page would display “… Pre-painted Miniatures (2023).”

This again happened a couple hours ago, so I tried logging into my modem to use its wifi, and it is correctly going to the new site. The router however is going to the old site. I did a factory reset on the router to ensure it was not storing any information. After doing that, then I was able to access the new site for a couple hours, but now it has gone back to pointing me to the old site.

Since I have tried powering off the router, and doing a full reset, I know for sure the cache is getting cleared, as it works fine for awhile after I do this. Something is then passing the old dns info back to the router? What could do this?

I finally figured out how to resolve this issue. For reasons I don’t understand, my router would initially grab the correct DNS from my ISP, but then later would get served an older DNS. This happened consistently for 2 days. Pretty much no one on the internet has had this issue – or at lease that is what my Google searches resulted in. I tried typing the issue into ChatGPT, and it gave me a list of about 10 things to check. One of those, was to took at where the router gets the DNS info from. The default setting was my ISP. I changed it off of my ISP, and selected the source to Google. It has been working fine for 12+ hours now, so I feel very confident it is fixed.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.