Install wordpress in subfolder but make it appear in root

Has anybody been able to get wordpress installed in a subfolder but make it accessible via the root? As in, wordpress is installed in, but I can access the site directly (like I’ve followed the instructions found here to the letter but I get error 500 on links to pages. Either something is wrong with the permalinks generated by Wordpress, or something is wrong with the way the server of my host is configured.
This is what the htacess file looks like

    # These Lines Added By Hosting Company please do not remove
    <IfModule mod_suphp.c>
    suPHP_ConfigPath /home/mypath/public_html

<Files php.ini>
order allow,deny
deny from all
# End of Hosting Company entries

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

# END WordPress

All you have to do is place all the files in the /wordpress/ directory, then move the index.php and your .htaccess file to the root. Then open index.php in your code editor and edit the path to load wp-blog-header.php to include /wordpress/ (or whatever you have actually named the directory)

/** Loads the WordPress Environment and Template */

Hope it helps. :smile:

Here’s a screenshot of a directory structure with this setup just with my directory called “wp”.

Ignore the index.html file. Not sure why it is even there. :stuck_out_tongue:

Sorry but no, it doesn’t help. The include is fine and working. My problem is that pretty permalinks don’t work. It was pretty clear from what I posted.

Sorry my first response was not very accurate to your situation. :frowning: I assume you’ve tried to save the permalink settings again in the dashboard?

Yes, I did.

Well, after wasting an outrageous amount of time on the problem and actually reinstalling the script from scratch in the root because I was unable to get it to work, I tried redoing the process from scratch on a different website I have. The steps were: disable pretty permalinks, copy index.php and .htaccess from the wordpress subfolder to the root, adjust the index.php in the root to include the loader
/** Loads the WordPress Environment and Template */
require( dirname( FILE ) . ‘/wordpress/wp-blog-header.php’ );

as per the Codex, then reenable the pretty permalinks. It seems to work without a hitch (fingers crossed), unless any other gremlins show up. The real culprit seems to have been a plugin I was using, which was probably enabled on the first website I tried it, because on the second website it was disabled and realized it was to blame because trying to activate it caused the second website to crash as well with 500 internal server errors. Hopefully this helps somebody else and your lesson from this would be to always remember to check for unlikely causes when encountering problems. Apparently the problem wasn’t a wordpress bug or the htaccess file, but a third party plugin (in my case a collection of functions I cobbled together myself).

Glad you got it to work. :smile: