Index of /phpmyadmin

I am still working on getting phpMyAdmin up and running…

When I put http://localhost/phpmyadmin into the address bar I get an index of my phpmyadmin folder.

Also my error log reads:

[Date] [error] [client xxx.x.x.x] File does not exist: C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/favicon.ico

Thanks.

1 Like

W_b,

That sounds like a combination of:

Not enabling PHP:

#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:/PHP/"
LoadModule php5_module "C:/PHP/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL

Not preventing directory listings

Options -Indexes

and not configuring PHPMyAdmin

http://localhost/phpmyadmin/install/

The Error was because there was no favicon (which is typical in an Apache install).

Regards,

DK

I checked that PHP was enabled properly and had to fix a few typos…

The Options directive in B[/B] is set to: Options Indexes FollowSymLinks, and

Now http://localhost/phpmyadmin/ is reading this file:
/* vim: set expandtab sw=4 ts=4 sts=4: */

???

W_b,

That’s commented out. It appears to be internal info (for phpmyadmin?).

For PHPMyAdmin to work, you MUST configure it correctly. The localhost/phpmyadmin/install/index.php file will help you do that but, if you still have problems, copy the following to your phpmyadmin directory as config.inc.php (USE config.sample.inc.php as a guide, if necessary):

<?php
/*
 * Generated configuration file
 * Generated by: phpMyAdmin 2.11.7 setup script by Michal &#268;iha&#345; <michal@cihar.com>
 * Version: $Id: setup.php 10748 2007-10-10 07:30:59Z cybot_tm $
 * Date: Fri, 27 Jun 2008 08:31:11 GMT
 */

/* Servers configuration */
$i = 0;

/* Server localhost (config:root) [1] */
$i++;
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['auth_type'] = 'config';
$cfg['Servers'][$i]['user'] = '{user}';
// replace {user} with your MySQL root user name
$cfg['Servers'][$i]['password'] = '{MySQL root password}';
// replace {MySQL root password} with your MySQL root password

/* End of servers configuration */

?>

Regards,

DK

I copied the above file to my config.inc.php (again) and I am still receiving the same file in my browser. Could my phpmyadmin folder be in the wrong directory: htdocs

I am not sure what else there is???

W_b,

Unless you’ve created a VirtualHost for phpmyadmin, it’s in your localhost directory, i.e., by default, that’s htdocs.

Did you bother to run the index file within the install directory?

Regards,

DK

the link for the install (localhost/phpmyadmin/install/index.php) returns broken in the browser…

In the files should the servername read 127.0.0.1:80 or 127.0.0.1:8080 (not sure if this makes a difference- but I played around with these and now the browser is returning This Webpage is Not Available)…

W_b,

OMG! You’ve got IIS running, too? I’ve told IIS it’s not allowed to start and don’t have the 80/8080 problem.

As for the not available problem, be sure that PHP’s enabled and that the .htaccess for the install directory does not block your access.

Regards,

DK

I would also advise that you change the directory name from /phpmyadmin/ to something else to keep script kiddies from even knowing you have it installed. An ounce of prevention…

FC,

Right - but only if it’s on a production server. Using that on a test server should cause no problem.

Thanks … and Welcome to SitePoint’s Apache forum!

Regards,

DK

Please clarify both directions:

  1. IIS do not believe I have it. I went to add or remove components in control panel and when I click to remove IIS it wanted to install…I assume an install means that it was not found on my computer…

  2. how do I prevent the .htaccess from blocking my(phpmyadmin) access to (what)?..

Thanks

W_b,

If you went to Start | Run services.msc and IIS is not in the list of installed services (or is NOT running), you don’t need to worry about it.

That would depend upon what’s in your .htaccess file (or even if there is one). http://localhost/phpmyadmin/install/index.php should get you to a configuration screen where you can answer the questions and it’ll create the configuration.php file in the phpmyadmin directory and (if I remember correctly) DELETE your install directory (sorry, it’s been too many months since I’ve gone through that).

Regards,

DK

that link is broken when i go to it…