How to stop IE adding www. and .com to addresses?

Does anyone know how to stop IE from doing this? I’ve been prodding around in “Internet Options” but can’t spot anything…

can you be more detailed on this.

what are typing in the address bar.

usually .com is accepted by browsers as default.

like if there is any domain registered with “” and if you will type “hello” in address bar then .com gets automatically added at the end of domain name.

this is what i have noticed many times.


Yes, the problem is if I need to access an internal site called “fred”, IE automatically adds www. and .com and takes me to instead. I don’t want it to do this.

If you are talking about a file stored locally on your own computer and you are typing the address into the address bar of the browser then you need to use file:///C:/ followed by the path to the file.

e.g. this is where my local files are stored:


Of course you could just double click on the file from windows explorer and it will open in your current browser anyway.

I’m not sure if this is what you meant though :slight_smile:

Try typing a slash on the end

If you type http://fred/ or even just fred/ then IE should see that the address is complete and should not go adding the .com on the end.

The alternative is to switch to using a different browser where the option to turn off the automatic adding of TLDs is easier to find.

If you really want to turn it off in IE then you need to edit the registry to do it. The key you want is HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
where you will then find four entries for trying the address with .com .org .net and .edu on the end.

IE is adding .com because when the computer looks up “fred” either first as a NetBIOS name, then local DNS cache, then DNS server, etc. If nothing is found for “fred” it adds .com, as an auto correction in case the user forgot to add it. As long as IE can find an entry for “fred” that points to an IP, it will not auto correct.