How do I find out if a website's firewall is blocking my IP?

Every now and then I am unable to access a website due to my IP being blocked by the web server’s firewall. I’m not sure why it happens, but I’ve even been blocked on my own website and had to remove my IP from the blocklist.

For around 6 months now, I have been unable to access which is my favourite web stats program. I can access it through a VPN or Proxy or any device not using my IP. I have written to the owner asking him to check to see if my IP has been blocked but he says the firewall is not blocking any IP’s.

For months I tried other stats programs but always found that I preferred w3counter. I would really love to pay for it instead of using the free version as there are some awesome features, but if I can’t access it without using some slow VPN or proxy, that’s just not going to happen.

So basically I am looking for any suggestions as to what I can do to troubleshoot this. Since losing access, I have even reformatted, but it’s definitely not a problem with my computer because it happens on any computer on our network. So it must be relating to my ISP/IP.

Now the only issue I can think of is that my IP has been blocked by the firewall and yet the owner says that his firewall is not blocking any IPs. So what steps can I take to troubleshoot this? The last website I got blocked from said that while their firewall wasn’t blocking my IP, it wasn’t configured to accept connections from my IP range, so I forwarded this to Dan at w3counter but it didn’t help so I am out of options.

Any advice would be greatly appreciated, thanks :slight_smile:

Maybe it is fault of your ISPs DNS server?
Have you tried using for instance as a primary DNS server?

Thanks for replying.

I have tried accessing using both the default dns and Google Public DNS ( as you suggested and even OpenDNS, but none of them work.

It is the only website I cannot access and is driving me crazy.

Do you have any more suggestions?


Have you tried telnetting to w3counter port 80 just to see at which point you are being cut off.
telnet 80

And can you ping or pathping ?

I cannot connect to it with telnet on port 80 but I can ping

Are you using any form of adblocking?

No I am not using any adblocking plugins and I can’t access it from any computers on my network even using different browsers. However I can access it easily by using a proxy or VPN.

Did you bring the matter to the notice of your ISP? I think the problem is with the ISP…

After possibly 6 months, I am now able to access again. It happened out of the blue, right after I noticed around 500 page views being lost from my stats, twice. Pages that had 1500 page views went down to 1000 and now around 500. I’m guessing that the owner of had some server issues and in fixing them or changing servers, my IP was no longer blocked by his firewall.

you can’t tell unless you try other server or ip to connect to it… if they can then your ip is pretty much blocked

My IP was unblocked for about a week and now for the past month or so it has been blocked again.

I went to see my ISP and they tested it and worked out that the IP has been blocked. They have systems running from a different ISP range which connects fine. W3counter’s firewall is definitely just blocking my IP.

It has been blocked for over 6 months and the owner denies that my IP is being blocked so I basically have no course of action except to always connect through a proxy.

I run a hosting company and every now and then a client’s IP gets blocked and I unblock them very quickly and apologise and explain that the Firewall is there for security and every now and then it will block an IP when the user is not necessarily malicious.

However as I have worked out from my side and my ISP has confirmed that the ISP is definitely blocking my IP, I don’t know what his problem is. I’ve even expressed my desire to upgrade to his paid package, but I first need my IP to be unblocked. But he just tells me that there is no problem and that the Firewall is not blocking any IPs.

But he just tells me that there is no problem and that the Firewall is not blocking any IPs.

That’s because the firewall is not blocking any IPs. I don’t pay for a hardware firewall and the front-end server only runs APF to block non-public ports.

There are no individual IPs or IP ranges blocked. The deny_hosts file is empty. Everyone can access port 80. I even double-checked iptables to make sure there wasn’t some rule in there I don’t know about. No, there are no IPs blocked.

I didn’t make any changes to the server or configuration a few weeks ago when you said you could connect. I haven’t made any changes since then. The server hasn’t been rebooted in 161 days.

If you can’t reach it, the block is somewhere upstream, somewhere I don’t control. I have no reason to block you or anyone else from the site.

It’s too late to edit, but… can you access other sites of mine? Try something else from my signature.

It’s a few months later and I am still unable to access wherever the blockage may be.

Thank you for at least providing some assistance with this. I can load up the W3ROI website in your sig, but not the DialShield website. Is there any server difference or anything like that? From what I can see they are on the same server, so that doesn’t make sense in itself.

Also I can ping and, even though they appear to be from different IPs.

I have no idea where this block could be coming from but it is driving me crazy because i basically can’t load up any pages on my own website. I upgraded to a paid w3counter account, not that I was expecing any difference, but anyway.

I’ll talk to my ISP again, but basically they showed me that they use 2 ranges of IPs and 1 was blocked and the other worked. So they changed me over to their other IP range and I could load up W3counter for a few days or so and then it stopped working again.

So I’m really not sure what to do. I’m going to hire some freelance networking specialist to try and find out where exactly the block is, if that’s possible.

But I’m pretty lost and angry because honest W3counter is just so much better and nice to use than GA and the other programs that I’ve tried.

W3ROI and DialShield are hosted on the same server.

So that doesn’t make sense then. I mean lets say it’s on my end. Since I can ping the websites but can only load one, and if W3counter is on a different server which judging by the IP it seems to be then I just don’t get where the problem could be. I’ll try bypassing my router and see if that helps.