How do I configure xdebug into sublime text 3


I got my php and mysql to work based on that link.

My php website is for example:

phpmyadmin for mysql for example:

So far I managed to configure xdebug in php and I type the command like
pkg install php-xdebug and in that php.ini I have to add the

xdebug.profiler_enable = 1

xdebug.profiler_output_dir = /tmp/profiler






then I restart the apache and then when I load my info.php page it
contains the xdebug page that like this in that picture. After that then
I follow the instruction on that link![|690x381](upload://mzETt9vQSAOKkYiK4A8UMvpODbH.jpg)
for how install xdebug for sublime text 3. I install package for
sublime text 3 and select xdebug client to install. After that then
created a project folder called awesome.sublime-project and made into a
new file. In that new file I created





     "follow_symlinks": true,

     "path": "."



"settings": {

   "xdebug": {

     "url": "http://myipaddress",

      "path_mapping": {"//davidjonesfolder/davedataset/daveserver/usr/local/www/apache24/data/awesome" :





Unfortunately it didn’t work when debugging with hello world page.

Hi James,

I don’t use sublime myself, but what is happening (or not happening)?


It suposed to debugged my hello.php file and it still didn’t work, just like this video at 6:39

Ok. The video shows how the Xdebug setup should be working, but what isn’t happening on your setup? Can you not call up your app in the browser, can you not set a breakpoint? What is broke?


It suppose to show the breakpoint just that video and it doesn’t show more details. Also, there is no debugging broswer just only debugging. How do I fix it.

Did you save your project as a project?

I have no experience with this, so I am just guessing…


yes I saved as a project like awesome.sublime-project and here’s the picture of what it looks like:

In that awesome.sublime-project file it contains the configuration:
“path”: “//FREENAS/davidjonesdataset/davidjoneswebserver/usr/local/www/apache24/data/awesome”
“xdebug”: {
“url”: “”,

Then i when and try the debugging website like but it still didn’t work.

Are you using a VM for your test server? And you also set up the VM like in the video to run with xdebug, including adding the proper IP?

I’ve installed ST3. If I get some time, I’ll try and see if I can get xdebug to work.


yes I’m using vm for my test server. For setting my vm, I used my old pc as a vm and I used freenas. I tried to setup xdebug just like that video and it didnt work. When I visit, I was to paste the phpinfo code based on the confuriation of what I did to configure the php page.
for example, my php website for example:

Here’s the photo of xdebug:

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.