Homestead Vagrant IP Address not within allowed ranges

Just trying to do a fresh install on Mac Catalina and I get the following message when launching Homestead for the first time:

The IP address configured for the host-only network is not within the
allowed ranges. Please update the address used to be within the allowed
ranges and run the command again.

  • Address: 192.168.10.10*
  • Ranges: 192.168.56.0/21*

Valid ranges can be modified in the /etc/vbox/networks.conf file. For
more information including valid format see:

I can’t find the conf file (even when seeing the hidden files), and don’t know enough about this stuff to understand the linked file.

Any insight would be gratefully appreciated

(I’ve moved this to “server config”, I can’t see any PHP-related stuff in this topic.)

1 Like

Hello again.

Seemingly I had this topic in the wrong place and since its been moved the responses have disappeared.

Rohit_Luck said:

Edit the Vagrantfile in the homeasted directory on line 29 to create private network. This allowed me to ping the 192.168.10.10 IP successfully and connect to database from HeidiSql.

Create a private network, which allows host-only access to the machine using a specific IP.

config.vm.network “private_network”, ip: “192.168.10.10”

I don’t have a line 29 in the Vagrantfile. It does end on line 28, so I tried inserting the above in on line 29 without any luck

The missing post was deleted because it had been copied from another site without attribution, which is not permitted.

The original post was made here: https://laracasts.com/discuss/channels/servers/cant-connect-to-homestead-ping-1921681010-fails How relevant that is to your issue, I don’t know.

Ok. I don’t knoiw how relevant it is as its all way over my head.

I’m following ‘PHP & MySQL: Novice TO Ninja’ where it describes how to set up the virtual server. It all worked fine on another computer a few months ago. There are 4 elements you havce to install: Git, VirtualBox, Vagrant & Homestead, and i’m not sure what each does or which one is attributing the IP address

Vagrant is doing that.

The /etc/vbox/networks.conf doesn’t exist yet, you have to create it, with the following contents:

* 192.168.10.0/24

And then try vagrant up again.

Yes, this seems to be some new behaviour in VirtualBox. Very, very annoying.

1 Like