Help with PHPadmin error

Hello my good friends

I had carried out a wampserver installation and had my database set up and running smoothly with phpadmin with out password. Now the database is near completion and needed to finally set a password. After setting the password I go the following error;

---- MySQL said: Documentation
#1045 - Access denied for user ‘root’@‘localhost’ (using password: NO)
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

I have checked the forum for similar issues that relates with xampp but it has not helped. my current file has this current settings:

$cfg[‘Servers’][$i][‘verbose’] = ‘localhost’;
$cfg[‘Servers’][$i][‘host’] = ‘localhost’;
$cfg[‘Servers’][$i][‘port’] = ‘’;
$cfg[‘Servers’][$i][‘socket’] = ‘’;
$cfg[‘Servers’][$i][‘connect_type’] = ‘tcp’;
$cfg[‘Servers’][$i][‘extension’] = ‘mysqli’;
$cfg[‘Servers’][$i][‘auth_type’] = ‘config’;
$cfg[‘Servers’][$i][‘user’] = ‘root’;
$cfg[‘Servers’][$i][‘password’] = ‘*****’;
$cfg[‘Servers’][$i][‘AllowNoPassword’] = false;

The password was empty originally but i set it to ***** (which is my password) and the AllowNoPassword was set to ‘true’ i changed to false.
I then restarted the server.

If I go to cmd prompt , it would ask for my password which i enter and i can have access. But if i go to phpadmin it would show the error but when i click on the ‘new phpadmin window’, it opens the interface without requesting for password which is strange.

Can somebody please suggest how i can get phpadmin working by setting up the password correct. Many thanks.