Help with migrating Wordpress (Lost categories)

Please I tried to migrate my wp site from its original domain to a sub domain so I could carry out some development before moving it back to the main domain, everything went well using the method here but the only issue I’m have is that, all the post categories were removed. All post went under UNCATEGORIZED.
Please I need help on this ASAP.

I look forward to a quick response.

1 Like

Check your database. It sounds like it didn’t export properly.

am actually using godaddy and i did a backup using the godaddy backup option on MSQL database section, created a new database and uploaded it there. right now i can not even login, it tells me invalid username when i tried logging in as admin. please help.

I actually used Notpad++ to edit the database (changing urls the the sub domain…

You can’t log in to phpmyadmin in your Godaddy Manage Hosting section of your account?

i can…

Then use PhpMyAdmin to export your database to your desktop so you can check it.

I have exported it. the file is over 300mb so i cant import it using phpmyadmin… is there any other way out?

Have you checked the database to see if the term_relationships table has not been corrupted?

please can you send your email lets go further?.. thanks

This is a public forum, @meltechgrp, and we like to keep all our discussions public so that everyone has the chance to participate. I’m happy to help you, and I’m sure others are also, but let’s keep it in this thread.

1 Like

i have been able to export the database from godaddy (phpmyadmin), but like i said, the database is quiet large (300mb) how can i import it to godaddy without server timing out…? this is just my problem

Thanks for your time WebMachine

I don’t understand. Isn’t it already in Godaddy? When you export a database, you don’t ‘move’ it, you make a copy of it and save it to where you want to export it (in this case, to your desktop).

The file is now on my desktop, and i want to upload to my godaddy database using SSH.
i have used the command source c:\db\database.sql; but still not working… it shows 'failed to open file c:\db\database.sql error: 2

I don’t think I’m getting a direct response to my questions - where was the database to begin with? On Godaddy? If so, why would you want to upload it again? When you exported the file to your desktop, that does not mean that it is no longer on Godaddy. Exporting does not move the file, it copies the file.

Also, did you check your database to see what happened with the category assignments?

Though database files are, erm, files, I would not try to “upload” them like I would for other files.
What you really want to do is “import”.


If you read my previous message you will see where i said i wanted to move the site to a sub-domain ( so i can redevelop it and change theme before moving it back to the normal domain ( in other not to disrupt public users. Now to do this, the database needs to be edited (change URLs etc which was why i downloaded the database to my PC for edit. The problem is uploading it back to the godaddy web server. The database is about 300mb which is too large to upload via PhpMyAdmin. I needed an option.

But i have been able to upload it using SSH remote transfer.
Thanks so much for your time, i really appreciate.

But again, now i changed the wordpress theme and i discovered that all posts thumbnails have disappeared. How can i restore post thumbnails please… ?

Which theme did you change to? Perhaps that theme does not have the posts thumbnails enabled.

I changed to TheFOX theme… please how can i get the posts thumbnails enabled ? thanks

The place I’d start is by comparing the two themes template files. In particular, whether or not the previous template had the_post_thumbnail() and the newer themes template file did not.