Form Mail stopped working


A client has a web site, which I was formerly hosting on a dedicated server leased from Fasthosts running their Matrix control panel. It has a contact page where users can fill in their details and fire off en email to the client. Now I’ve moved to one of Fasthosts Plesk servers and it will no longer work; it gives an internal server error:
HTTP Error 500.19 - Internal Server Error
The requested page cannot be accessed because the related configuration data for the page is invalid.

More info:
Config Error: Cannot read configuration file due to insufficient permissions

The file it’s complaining about appears to be web.config, which doesn’t exist in the folder it shows:

I’ve looked at the permissions for the folder and they seem OK. is where it should be (and always has been) - in cgi-bin, so I’m at a loss to know what’s going on. Unfortunately, Fasthosts just blank me, saying they “don’t provide scripting support”. Seems to me they should accept that it’s their responsibility, but if not, perhaps one of you out there might have an idea for me?

Here’s hoping.

Many thanks.

I’ve looked at the permissions for the folder and they seem OK.

Does perl call anything that requires permissions for anything?

This might be better in the server area, because likely the script itself is fine.


Are you using Matt’s formmail from Matt’s script archive (scriptarchive-dot-com)? As far as I know its config is self-contained. It should not have to depend on external configuration.

web.config is the configuration file for an ASP.NET application, however you are mentioning so it seems a perl script. I’m assuming the rest of the site is written in ASP?

This error only happens with, not with any other requests? If you can provide me with any further information, that’d be great.

Hope to hear from you.

I hope he’s not using Matt’s Scripts : (

Hopefully it’s at least updated or something.

Hi JawsOfLife

Thanks for your reply. The site is only HTML, so it’s interesting that you say web.config is associated with ASP.NET. Maybe that’s a clue.

The first line of the reply form looks like this:
<form action=“” method=“post” onsubmit=“return validateform();” id=“contactQuery”>

The thing is, it always worked fine on the old server and nothing was changed.

I have another site using CDO and VBScript to send an email, and that’s stopped as well, complaining that the ‘SendUsing’ configuration was wrong. I did find something on MSDN that said there were changes when moving to IIS7 and tried implementing their code, but got a syntax error I can’t work out when trying to set the SMTP server. All very confusing, but it seems likely that both problems are to do with the change of server, IIS version, or both.

If you’re any the wiser, I’d love to hear from you!




Thanks for providing me with the link to your I’ve visited it and got a blurb about error 500.

I noticed an Error code: 0x80070005
According to Microsoft on support-dot-microsoft-dot-com/kb/942055, this is caused by:
This problem occurs for one of the following reasons:

and the resolution for this is

Since the config error is “Cannot read configuration file due to insufficient permissions”, it looks to me Method 2 is most likely to fix this.

If that is already a solution you’ve tried, please let me know.
Tell me, do other Perl scripts work on this server? I wonder if it’s failing to execute all of them due to configuration issues.

Last time it was updated appears to be about 6 years ago.
Are there any modern formmail scripts available elsewhere?

Thanks for the various replies. I rewrote the mailing page in vbScript in the end, and it’s all fine now.

Perhaps formamil has had its day!



Are there any alternatives?
If so, what are they?