Foreign characters in the url help

I am switching hosting companies from justhost to vidahost. I have a site with foreign characters in the file names and folders. When I upload them to my justhost hosting they appear fine in the browser address bar, like they do here…[B]ä[/B]ndisch

However, when I upload to Vidahost hosting, the only way they can be handled is by encoding the special ‘ä’ character, for example…

I can also see the difference in cpanels file manager, at justhost the foreign characters in the file and folder listings display correctly, where as at vidahost the special characters are replaced with ‘�’ in cpanels file manager.

On a side note, all my files are encoded in utf8.

I’m pretty sure this is an Apache server setting. I’m trying to explain this to vidahost, but I’m not getting very far.

Can anyone shed any light on this?


The server’s language is, indeed, established by the httpd.conf. I’ve checked my test server (Apache 2.2 on a Win7 box) and it shows that the languages the server will use has been split off the httpd.conf into

# Language settings
#Include conf/extra/httpd-languages.conf

The languages file contains lines like:

AddLanguage sv .sv

# and

LanguagePriority en ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR ru sv tr zh-CN zh-TW

IMHO, Vidahost is not providing you the service you’re paying for so you may wish to consider the folks at WebHostingBuzz (in the UK?). I’m not sure whether they have or will configure multi-language shared servers but I’m sure that they will do so for VPS and dedicated servers. Use their ticket system to ask (or PM mattrussell - he’s in the SitePoint boards frequently) to be sure.