@font-face crashes Firefox

It seems that after hours of testing my CSS stylesheet, @font-face is crashing firefox. The weird thing is that when I remove the stylesheet and put it back in, it works again. Then it crashes after a few visits. Does anyone have any experience with this or ideas to fix it?

Thanks in advance!



@charset "utf-8";

@font-face {
    font-family: 'ArimoRegular';
    src: url('../fonts/Arimo-Regular-Latin-webfont.eot');
    src: url('../fonts/Arimo-Regular-Latin-webfont.eot?#iefix') format('embedded-opentype'),
         url('../fonts/Arimo-Regular-Latin-webfont.woff') format('woff'),
         url('../fonts/Arimo-Regular-Latin-webfont.ttf') format('truetype'),
         url('../fonts/Arimo-Regular-Latin-webfont.svg#ArimoRegular') format('svg');
    font-weight: normal;
    font-style: normal;


@font-face {
    font-family: 'journalregular';
    src: url('../fonts/journal-webfont-webfont.eot');
    src: url('../fonts/journal-webfont-webfont.eot?#iefix') format('embedded-opentype'),
         url('../fonts/journal-webfont-webfont.woff') format('woff'),
         url('../fonts/journal-webfont-webfont.ttf') format('truetype'),
         url('../fonts/journal-webfont-webfont.svg#journalregular') format('svg');
    font-weight: normal;
    font-style: normal;

@font-face {
    font-family: 'jrhandregular';
    src: url('../fonts/jrha-webfont.eot');
    src: url('../fonts/jrha-webfont.eot?#iefix') format('embedded-opentype'),
         url('../fonts/jrha-webfont.woff') format('woff'),
         url('../fonts/jrha-webfont.ttf') format('truetype'),
         url('../fonts/jrha-webfont.svg#jrhandregular') format('svg');
    font-weight: normal;
    font-style: normal;

I haven’t seen that myself, but FF does seem to have more issues with @font-face than other browsers (if posts here are anything to go by). Does it happen if you try a different font?

Have you tried switching the font references around into a different order - perhaps the latest Firefox now has the same issues with that order as some of the other browsers that the arrangement you are using doesn’t work with.

I thought that a different font could be the solution. So I replaced the main font () with a different one (). It worked initially when the new CSS file was uploaded, but then stopped working again.

Yes, I just tried this, but with no success.