Difference between php 5.3.5 and php 5.2.17

Hello, I’ve always been wondering why there is 2 versions of php… the 5.3.5 and the 5.2.17 version…

Why don’t we just use 5.3.5? when it’s stable?

I know there must be a pretty good reason but tried search on google, and doesn’t seems that I can find a answer really…

So anyone that can explain what the difference are, why we should use one over another? and so on.

Thank you alot!

The differences are really minor. It is just slow people incapable of keeping up with the times. Anyways there is no 5.2 version any longer. Every version below 5.3 is unsupported, completely no security updates and so on.

Ohh okay, it’s because at my host we’re running 5.2.17 - And I can see that build was released 06 Jan 2011…

I will contact them and ask, to upgrade!