Could not find a version that satisfies the requirement json

I want to deploy a Telegram group bot written in Python to heroku, but I get this error when I type git push heroku master:

Could not find a version that satisfies the requirement json

Here is my requirements.txt file:

requests >= 2.26.0
json >= 2.0.9
telegram >= 13.11

I’m using conda (Python3.9.7).

What did I do wrongly?

Is the package telegram something you created or is it suppose to be a package on PyPi? I am looking on PyPi and the only package called “telegram” is version 0.0.1. If this is a package that you created, make sure it is on heroku as well.

No, I didn’t create the module. It’s from python-telegram-bot module.