Compile PHP from source, and it seems that something is missing

Well I have tried to compile PHP from source on my windows desktop, by following this guide. It initially gave me some troubles as I use visual studio 2013 community that does not come with bison by default, but I’ve got by this eventually:

However, I run into several problems, which are very confusing:

First of all, some .dll files at the root folder seem to be missing, in the official windows build you see files such as glib-2.dll, icudt51.dll, libenchant.dll, but my compiled-from-source PHP has nothing like that, these .dlls are missing.
Official Build:
Manual Build:

Second, the folder /ext in the official windows build has all .dll files, while in my compiled-from-source PHP, there are no .dll files, and instead I get several folders of these extensions, and when I open the extensions I see object files and source browser intermediate files, no .dll at all.
official build:
manual build:

Now I am totally confused, did the build actually compiled successfully? Or did something go wrong? Or maybe it did not even compile at all? Can anyone help?

Well I suspect that PHP cannot be compiled using Visual Studio 2013(VC12), so I installed Visual Studio 2012 Express(VC11, which is supported). Nonetheless, it gave me this error upon running nmake command:

fatal error C1083: Cannot open include file: ‘malloc.h’: No such fil
e or directory
NMAKE : fatal error U1077: ‘D:\Development\VS2012\VC\BIN\x86_amd64\cl.exe’ : ret
urn code ‘0x2’

What does this even mean? Is there a way to fix it?

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.