ColdFusion server-specific error code 2

I have the developer’s version of ColdFusion 8 installed on a Vista 32-bit computer. It is installed as a stand-alone server. Usually it starts automatically when my computer starts, but now it doesn’t. So I tried to start it manually and this it what I got:

“Windows could not start the ColdFusion 8 Application Server on Local Computer. For more information, review the System Event Log. If this is a non-Microsoft service, contact the service vendor, and refer to server-specific code error 2.”

Having Googled for a while and not finding any solutions that worked, I did a system restore to 2 days ago (I’m pretty sure ColdFusion was working then). This did not work. So I uninstalled and delete ColdFusion, then re-installed it under IIS (for irrelevant reasons). Still the same error, which is over my head why the error would still be there. So after that didn’t work, I did another system restore to a point where I know ColdFusion worked. Still I get this same error. (It is now a stand-alone server again since the last system restore undid the new installation)

Does anyone have any suggestions? Most of the treads I found while searching were relating to Coldfusion 7 or lower and didn’t help me out, and the few I did find concerning ColdFusion 8 didn’t fix the error.

If you need anymore info please just let me know.

Thanks for your time.

I’m having the same problem with ColdFusion 9, developer edition, multi-server install on Windows XP. It was working for me at work today and now it’s not working for me when I tried booting it up at home. I tried re-booting. I tried uninstalling the last Windows update I received. I’m still unable to boot ColdFusion.

Did any find a solution to this?


It was working for me at work today and now it’s not working for me when I tried booting it up at home

Stupid question I know but just to make sure - Is ColdFusion installed on the same machine that you’re using at home that you’re using in work? If it’s installed on a machine at your work then you’ll need remote access to see it at home.

Now clear that one up :slight_smile: - How are you trying to boot it up? Are you getting any error messages?

Have a look at the log files being generated by ColdFusion as they may give you a clue to the problem.

I found the solution last night. I thought about the things I did that day at work and I realized that I just started using CFBuilder to line debug and it was using port 5005. I check my ports when I boot my computer and sure enough, port 5005 was already used and that’s why my cfusion server wouldn’t start because the debugger couldn’t connect with that port.

It turns out that my CF Admin Server was using that port and that would start up right before my cfusion would start up. So, I edited my jvm.config file to have my debugger use port 5006 and updated the line debugger to port 5006 in the CF Admin, restarted CF and it worked!

I don’t know if this explains all the reasons for getting this error, but this is what my problem was and hope it helps others.

I ran into the same problem when I came into work on Monday and found out that it wasn’t the Admin Server itself, but that it was listening to the same debug port because it was using the same jvm.config file. To overcome this, I created a separate jvm_admin.config file and pointed the Admin Server to use that file instead of the default one. I even created a Windows Service to do that so I don’t have to manually do it every time. Here’s the website I found that showed me how to do that:

www dot n8williams dot com/devblog/coldfusion/multiple-coldfusion-instances-with-separate-jvm-configs-as-windows-services